Whenever I try to update one of my apps, it downloads 79%, stops for a moment, then the progress bar resets and one of two dialog boxes appears:

Unable to Download Item

"App Name" cannot be downloaded. Please try again later.



Unable to Download Application

"App Name" could not be installed at this time.

[Done] [Retry]

In the case of error #1, the app then returns to normal, but has not been updated. In the case of error #2, it sits at 0% and cannot be opened. Retrying simply repeats.

This does not happen with every app. Some apps simply install as expected.

I have a 4th generation iPod touch running the Evasi0n jailbreak of iOS 6.1. Rebooting does not resolve the problem, nor does launching in Safe Mode.

  • 1
    Happens to me too sometimes when downloading over weak internet connection/3G. I have no jailbreak. Sometimes I wait until a stronger connection and I'm able to redownload. Commented Mar 19, 2013 at 1:02
  • 2
    I have had this happen when there wasn't enough free space left on the phone for the downloaded update to decompress/verify before replacing the old version. Does it seem to happen only with larger apps?
    – Kent
    Commented May 29, 2013 at 12:22
  • something in the overriding OS files (jail break) is conflicting with something that the app is programmed to work with. I know that's not what you're looking for, but it's the most logical conclusion Commented May 29, 2013 at 14:13
  • I have a strong Wi-Fi connection and plenty of space. I expect it probably does have something to do with the jailbreak, but even trying it in Safe Mode doesn't work.
    – Tuesday
    Commented May 29, 2013 at 15:36
  • 1
    I feel like we're leaning towards jailbreaking being the problem. I suggest backing it up (if that works with jail broken phones) and restoring the phone through iTunes to a legit status and see if the app will then update.. If so, do you need to jailbreak anyway? I recommend against, but others do have good reasons to do it Commented May 31, 2013 at 20:16

6 Answers 6


When this happens to me, I find it starts because a download was interrupted.

To correct, I find it easiest to use my computer to install the update, which corrects each app it updates.


I was able to recover from the error type #2 described in the question by deleting the /var/mobile/Media/Downloads/downloads.*.sqlitedb file - where the asterisk matches some possibly random digits.

The file contains information about available (and partially downloaded) updates and the removal of the file causes the disrupted updates to become available again in the App Store. When you start App Store on the device, the file is re-created.

Now, it should be possible to update the apps that previously were caught in the failing update loop directly from the App Store.

Note, that deleting the file mentioned requires a jailbroken device with either iFile or some similar app or sshd running on the device.


This happened to me around the time I switched Apple IDs. When I first started purchasing/downloading content from the iTunes store, I was using one Apple ID, and now I use another.

Any time I attempt to update an app that I first downloaded using the not-currently-logged-in (via Settings > App Store) user, I get one of these errors.

It became such a pain in the ass that, each time I encountered one of thees apps, I deleted the app and downloaded it fresh using my new Apple ID.

If you think this might be the case, you can Get Info on any app in iTunes, and see which Apple ID it belongs to.

  • Thanks, but it's definitely nothing to do with Apple IDs.
    – Tuesday
    Commented Jun 11, 2013 at 20:36

I had 3 app's in my update page of my iphone6, but nothing would happen when I attempted to update them. Apparently the page was not requesting sign-in information and restarts wouldn't fix it. What eventually worked was to go to a page in the app store that required a sign-in, like wish-list, then sign-in on the update page. This last step had no effect until I restarted and visited the update screen, then I was prompted and the updates completed. So in short, get the update screen to prompt you for a sign-in.


I had this problem in the past when my iPhone 4 was jailbroken as well.

I believe that it has something to do with the apple ID used to download the app. Try logging out of the apple ID (within the App Store, usually found at the bottom of the featured apps list), hard restart your device (holding down both sleep and home until device turns off), and sign back in to your ID in the App Store.

Test drive it at that point by installing (or updating) a few apps.

Let me know if this worked. Good luck to ya.

  • 1
    Thanks, but I've definitively ruled out Apple IDs as the problem.
    – Tuesday
    Commented Jun 11, 2013 at 20:36
  • How are you sure? Commented Jun 12, 2013 at 15:27
  • Well, other apps purchased with the same Apple ID update just fine. I've completely restored my iPod, though, so it's moot now. It's extremely probable it had something to do with my jailbreak.
    – Tuesday
    Commented Jun 14, 2013 at 17:13
  • Yes, the jailbreak AND its relation to the Apple ID. It's not a problem with your Apple ID, rather, it's HOW your device manipulates it. Well, as long as you fixed it, it's left to history. Cheers. Commented Jun 18, 2013 at 1:57

I solved this problem by syncing to iTunes and downloading the app directly from my desktop iTunes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .