This has been happening for months, and I have no idea what's causing it.

Something on my Mac keeps mucking with disk permissions, and it seems like a trivial set of stuff

  • Java-related library files and the Applet plugin
  • Core Graphics headers
  • Some network headers, like a few files in the arpanet group
  • My hosts file (in this case, I know that the thing touching the hosts file is the Gasmask application)

However, whatever it is that is doing this, it completely wrenches up a lot of file-related actions. The two most high-profile issues:

  • Archive Utility becomes unusable; it hangs indefinitely and I have to force-quit. 3rd party archive utilities like The Unarchiver don't experience this issue, so I've switched to using The Unarchiver.
  • The most annoying one is that the "Reveal In Finder" action in Alfred doesn't work. I use this functionality all the time and it constantly stops working.

If there are other issues, I haven't directly noticed them, but I'm sure there are other things I can't find. Whenever one of these things starts to happen, I run a permission repair, and everything goes back to normal for a little while, then one day *bang* it starts again.

Has anybody else experienced something similar, or does anybody know if there's a way that I can track specific files' permissions modifications so I can see exactly what the culprit is? I have a great deal of software installed via homebrew and non-MAS avenues so I think it'd be pretty complicated to track it down exactly, any tips are greatly welcomed.

  • Look at /usr/bin/opensnoop (with a --help option) that will show files access
    – mmmmmm
    Mar 18 '13 at 0:28
  • @Mark I just checked, and a chmod doesn't count as a file open, so opensnoop -f wouldn't pick up a permission change only operation. But I think it's a fair assumption that anything changing the permissions of a file will proceed to use a file, so I'm still running a background opensnoop process with redirected output to check just in case. Mar 18 '13 at 4:01

I don't know if the permission issues are related, but revealing files in Finder not working and Archive Utility stopping to respond are both symptoms of the Apple Events bug that was introduced in 10.8.2.

I don't know if it was fixed in 10.8.3, but when that starts happening, you can terminate appleeventsd from Activity Monitor or with sudo killall -9 appleventsd (without -9 other processes stop responding for some reason). The issue will probably return within a few hours or days though.

  • Hmm. This seems like a similar but unrelated issue. I'll keep an eye on it though. For me, it's never just one application breaking at once, and repairing permissions always fixes the problem, so it sounds like something different. Mar 18 '13 at 13:44

Java had a zillion updates... No matter if I unchecked one in a browser, someone would say this version is approved.. I am running 10.8.2 and had such permissions issue.. library/Internet PluginIns JAVA APPLET Plugin.plugin File s/b lrwxr-xr-x Kept reverting to drwxr-xr-x

My browsers would spin bullets and eventually show open response..

I could not find this JAVA 7 update, so I had to take a risk and open

This is an alternative method for uninstalling Java 7 for advanced users familiar with entering commands on Terminal window. I was a Mac user with Windows knowledge only for typing command... Following the steps listed will uninstall Oracle Java 7 from your system. Note: To uninstall Java 7, you must have Administrator privileges and execute the remove command either as root or by using the sudo. Click on the Finder icon located in your dock Click on Applications tab on sidebar Click on the Utilities folder if item was loaded by Oracle. If 3rd party or not located...Double-click on the Terminal icon In the Terminal window Copy and Paste the command below: sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin

I ran permissions after and had no repairs..

I am new on making links from images, but I referenced this work around, and run no JAVA on my system. Info from Oracle.. Now google has given me a new issue.. So I will just un-install it.. Clean and do a new-install...

  • Unfortunately, I'm not looking to uninstall Java, as I'm a professional Java software developer so I need to have it. Mar 25 '13 at 1:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .