So. Assigned the password to my network. First time it worked great. But then, I had to resset the router. After that, I went and assigned the password again, but this time, when I try to connect to the network, it won't even ask for the password and won't connect at all!

Does anyone know what the hell is the problem?

(Using macbook air, running osx lion)

Also, tried resetting the router countless times. Did absolutely nothing.

Also, iphone connects and works with the router just fine.

  • 1
    Is the network listed in System Preferences > Network > Advanced? If it is, remove it from the list and try again. Mar 17, 2013 at 1:01
  • I... Seem to be unable to remove it from the list.
    – MNG
    Mar 17, 2013 at 1:11

1 Answer 1


You have to do the Unlock first (click on the lock icon and type your password), on the Network screen before going to Advanced tab, once in advanced click on the network and hit (-) sign.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .