I managed to fix this problem in a risky way, but it worked for me. Read below.

Pin 11 apparently carries out the following function :

11   GND     
If connected to GND the iPhone sends audio signals through pin 3-4
otherwise it uses onboard speaker.


My iPhone is stuck at the function of using an onboard speaker (dock), and only produces sound when connected to a dock or a charging connector. Whenever I take it out, the phone mutes itself except for ringtones.

I am guessing that some switching mechanism is stuck at that setting. Does anyone know if there is a specific pin-like switch that needs to be adjusted to fix this ?


I noticed that sound only plays when connected to the charging dock and powered on. Using the cable with no power OR without the dock mutes the phone. If I remove the iPhone from the dock while it's playing music, it continues for a few seconds and then mutes, the music player is still running on play, but with no audio output.


When trying to connect the AppleTV, I found the following evidence that shows how the iPhone thinks the dock is connected.

enter image description here

The iPhone was NOT docked at this time.

  • Have you inspected the dock port to make sure there isn't any debris on the 30 pin connection? Ignoring liquid damaged iPhones with corrosion I've still seen several that with this issue that were resolved by cleaning debris out of that port. I've always assumed that there was a strand of conductive material mixed in with whatever debris is in the port. I would use a light to inspect it, some compressed air to blow it out, a soft brush (unused toothbrush, small paintbrush, etc) to clean it out and another dose of compressed air. Hope it's something quick like that and not a hardware issue!
    – Mr Rabbit
    Mar 28 '13 at 15:15
  • @MrRabbit Well can't see anything lodged there, already tried cleaning the port :S
    – Render
    Mar 29 '13 at 1:02

I've fixed this exact problem by clearing out pocket lint from inside the iPhone dock connector with a paper clip. Hope that helps..

  • Lint was the problem in my case, too. I used pressurized air to remove it.
    – mklement0
    Jun 28 '13 at 23:05

I found a method that worked for me. If you're having a problem similar to mine and cleaning the dock did NOT work for you, try this at your own risk. Disclaimer : This method might permanently damage your iPhone, mine is out of warranty so it wasn't a big deal if I damaged it, I would still need to pay for replacement.

I don't know what may have caused the phone to lock at the docked state, but my first thought is that there is a switch mechanism inside the dock connector. All I did was get a key and jam it there, and rotate it a bit until it got fixed.
Note: If I inserted the key there and did not rotate it, the problem is fixed temporarily until the key is removed. The only way I got rid of the problem completely is to rotate the key and push the pins downward.

If you try to insert the key and remove it, the problem still persists. I had to jam the key in deep and rotate it a few times (gently) to permanently fix this issue.

Make sure you insert the key in the middle - left part of the dock connector, that's where pin 11 is located (I think).

enter image description here

After placing my phone on a dock again, I lost control over the sound. I did the same method with a bit more rotations using the key and now the problem is gone 100%. Not sure how, not sure why, but it worked.

If using a Key seems too risky for you, read below

Use cotton wool from the end of a qtip (but not the qtip it's too wide to go in) use a nail file or a very thin screw driver to put the cotton wool inside the docking part and gently move back and forth. If you use alcohol even better.

(PS i tried a lot of compressed air and a toothbrush and it didn't work - the iPhone was about 3 years old so it was filthy inside. The cotton wool came out surprisingly dirty - ie the tooth brush and the compressed air will work if it's a little dirty or there is a little bit of lint - but not if its very dirty.)

Good luck.

  • A bit dangerous as you mention, am I wrong in guessing your phone is jailbroken? For my friend with the same issue a cleaning and hardware reset cleared the issue on a non-jailbroken iphone. May 14 '13 at 20:10
  • It is Jailbroken, but has no effect on the problem.
    – Render
    May 14 '13 at 20:25
  • The same problem - non jailbroken iOS 7. The volume go back when pushing in the middle-left (as mentioned in answer) Jul 20 '14 at 0:17

When I see this issue, it is usually because the dock connection has liquid damage. Check for a rectangle near the pins. It will either be white for no liquid contact or a pink/red color indicating liquid contact.

  • I can't seem to find that rectangle, do you have a picture reference ?
    – Render
    Mar 29 '13 at 1:01

Clean the dock connector with a qtip and a tiny bit of alcohol gently.

After that, plug it into your computer to backup and do a full reset, restore from backup, and all should be well.

  • Unfortunately that didn't help :(
    – Render
    Mar 29 '13 at 1:02
  • You did an "erase all data" reset? Mar 29 '13 at 16:37

I charge my phone for about an hour without touching it, after that, the problem is gone


All I had to do was grab an old tooth brush with frim bristles and scrub under there really good with some alcohol and electronics cleaner

EDIT- It's still not working all the time so I probably have to keep at it periodically until its goes away completely or I can do a hard reset.


I ended up using a very small screwdriver and while cleaning out the dust.

When I pushed a little bit on the right side of the white part under the connector, I felt it pop back in place. Now the issue is gone.

Agreed I had a similar issue checked for corrosion (none found) I cleaned w/ toothpick nothing. Took a smaller flat head drew driver apply gentle pressure to the 30 pin connector. The sound/docked indicator disappeared intermittently. It seemed to be at the bottom left part of the connector as you are facing the iphone 4. I repeated the process in the area mentioned and a small dull click occurred. The connector seemed to be reseated. It is now functional. Small pressure. This fix has the potential to go really wrong!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .