1

When I use the uptime command on OS X, this error is printed:

$ uptime
uptime: /dev/ttys003: No such file or directory
20:57  up 36 days, 22:10, 3 users, load averages: 1.77 1.37 1.75

By running the who command, I see that there is another terminal logged in -- but I don't have any other terminals or SSH sessions.

$ who
Kevin    console  Mar 10 17:49 
Kevin    ttys000  Mar 14 17:45 
kevin    ttys003  Mar 14 20:59

This is kind of annoying. How do I get rid of the "No such file" message?

1
  • This might make a better resource if you explain what you (or the person who doesn't know yet) doesn't "get". What's the problem to be solved here basically?
    – bmike
    Mar 15, 2013 at 17:23

1 Answer 1

4

Terminals are numbered sequentially. The first terminal opened was 000, so I opened 3 more so that the 003 number would be used. I closed all extra terminals and uptime worked without error again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .