Recently, I have tried a FreeBSD 7.4 i386 Install DVD, just to see some screens of FreeBSD on my Mac mini Intel 2006. I was going to see (to remember) just several dialog screen of and perhaps I would try the Live CD feature of FreeBSD. And I did see them and later I ejected the FreeBSD Install DVD without changing anything on Mac mini's harddisk.

But after restart I found that Mac mini would not boot Mac OS X Leopard. Apperantly, some code on FreeBSD DVD must have tampered with someting on the Leopard harddisk.

When I checked the harddisk using another (working) Leopard with #gpt -r show disk0 as shown in this post: How to fix broken EFI partition? , the first entry is "pmbr" on that post, whereas it's "mbr" in mine, all other partitions and sizes are the same which makes me think that there's an easy fix for this problem.

Would you advise me to try the procedure on that post, would it help?

1 Answer 1


Try this:

  1. Put into the CD tray the OS X Snow Leo install disk
  2. Restart computer
  3. Hold OPTION (Alt) key, select OS X Installation DVD
  4. Open Disk Utility
  5. Select your disk, go to the First Aid Tab.
  6. Follow the instructions. The EFI data on disk shall be restored.
  • Hello Thank you for the suggestion. I remember trying that. I tried that once more to be sure. When I select the first aid tab, all options such as "Verify Disk Permissions" or "Repair Disk" are grayed and not selectable. I guess that's because the OS's partition cannot be mounted by Mac OS X Installation DVD.
    – Terry
    Commented Mar 15, 2013 at 17:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .