13

I use Iterm2 on the Mac. Many times, I accidentally press Command+some key, so I'm wondering, is it possible to disable the Command shortcuts? Like Command+D for example, as I use tmux for split panes.

  • the most annoying of these accidents is ⌘+Q since Q is just next to Tab. The ignore shortcut below also works to disable this – Ciprian Tomoiagă Oct 31 '18 at 13:29
23

You'll want to override iTerm's default shortcuts with your own shortcuts to "Ignore".

Go to Preferences > Key and press the + button at the bottom of the Global Shortcut Keys:

Global Shortcut Keys

Then add an entry for Cmd+K and choose "Ignore" for the action:

Entry for Cmd+K

This disables Cmd+K.

-1

You could just go to Preferences > Keys and manually delete every shortcut with Cmd.

  • 2
    Those commands are not listed – mollerhoj Mar 15 '13 at 17:09
  • Please delete this answer. It is wrong and misleading. – Behrang Mar 10 '14 at 9:09
  • @Behrang we don't delete wrong answers for that reason alone. Can you explain he harm here or better, why exactly this is wrong. – bmike Mar 10 '14 at 12:35
  • 1
    The Preferences > Keys panel does not contain an entry for Cmd+K so there's nothing to delete that can fix this issue. – Behrang Mar 10 '14 at 14:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .