I've been searching and searching for a solution to my problem and I've seen a lot of people have similar, but perhaps not quite the same, problem.

My original HDD failed on my MBP and I'm in the midst of trying to replace it, I wanted to make sure it was the HDD that had failed, so after backing the drive up, I formatted it and began reinstalling OSX Lion, however it keeps hanging during the install process.

Next I managed to get hold of another 320GB HDD to try that one, however once I boot up the install disc and use DiskUtility, the drive does not appear. If I connect the drive externally via USB, I'm able to see the drive and format it to Mac OS X journaled, but once I connect it internally again, DiskUtility still does not see it.

After trawling through post after post, I've tried downgrading the firmware to EFI 1.6 (still no luck), I've also tried using masking tape to thicken the SATA connector.

The main answer to come back was that the issue was the SATA Cable Connector in the Mac itself, however I'm reluctant to spend money buying a new one as I'm not convinced that is the issue due to the following...

...I then connected a smaller (160GB) HDD which is a 5400rpm drive and amazingly this drive is recognised by DiskUtility and I can install OS X Lion onto it without any issue at all.

I couldn't care less about enabling the 7200rpm drive for the faster transfer speed I just want my Mac to recognise the drive internally so that I can get the thing back up and running.

Does anyone have any idea why my Mac recognises a 5400rpm drive, but not a 7200rpm drive?

  • it has nothing to do with the RPM but rather and more probably the disk model!
    – Macmaniman
    Mar 14, 2013 at 17:28

2 Answers 2


I'll bet you a dollar that its the cable.

  • If that's what it turns out to be, then that's fine lol. Just wanted to put the question out there as lower speed drives are detected fine. Cheers the response though :)
    – Matt Smith
    Mar 14, 2013 at 16:00

Without researching your model at all, the HDD may have a cache size too big for your mac to handle. I know once I had to jumper down a momentus XT to work in an old macbook C2D.

Maybe give that a look?

  • Its a good shout, never thought of that. Will give it a go tomorrow morning when back at work.
    – Matt Smith
    Mar 14, 2013 at 19:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .