I use my retina MacBook Pro to stream some videos from the web and play them, via AirPlay, on my Apple TV 3. Every now and then, when I switch to AirPlay, the video goes to the Apple TV, but the sound continues to come from the MacBook Pro. The only way to get it to work correctly is to restart the computer. I've tried the Sound preferences, but choosing the Apple TV there still doesn't send the sound to the device. Any thoughts on what may be happening?

  • is the system not sending any sound, or an pertiular app, like vlc or such?
    – Macmaniman
    Mar 14, 2013 at 18:33

2 Answers 2


This is a long-standing bug in the software with OS X Mountain Lion, that unfortunately Apple has not acknowledged or addressed. The simplest solution is to restart, but I don't like to restart my computer simply because AirPlay is broken.

Instead I do the following, which fixes the issue nearly 100% of the time, without a reboot:

  1. Turn off AirPlay Mirroring
  2. Open Terminal.
  3. Type in the following commands (pressing return after each):

sudo dscacheutil -flushcache

sudo killall -HUP mDNSResponder

You should see your AirPlay icon disappear and quickly reappear in your menu bar during this process. After that, fingers crossed, all should work again. I stole this fix from the Apple Support Forums and it has worked well for me.

  • Just to add, this is a widespread issue that impacts all Macs that support AirPlay Mirroring.
    – bispymusic
    Mar 14, 2013 at 14:29
  • Thanks, I'll try it next time I have a problem. To be honest, the MBP is my secondary Mac, which I don't use a lot, and, since it has an SSD, reboots fast. But it's still a pain to have to do it. Mar 14, 2013 at 15:30

This problem happens so often it's worth creating a command - assuming ~/bin is in your $PATH ...

echo "sudo dscacheutil -flushcache" >~/bin/retina
echo "sudo killall -HUP mDNSResponder" >>~/bin/retina
chmod u+x ~/bin/retina
  • I get file not found for the 1st command. is it the same path on 10.8.5
    – user58150
    Sep 26, 2013 at 10:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .