0

Following the instruction from Apple: http://support.apple.com/kb/HT4011

I can't get this to work for my multiple server logins, because they all have the same name (my user name). When I try to add the connected share to the Login Items nothing happens, because one with the same name already exists. How can I get around this?

  • Can you provide an example of two of these servers that have the same name? That will probably help us guide you to an answer better. – bispymusic Mar 14 '13 at 0:47
  • They are linux servers used for development. In each instance, I mount on my home directory hostname:/home/srobbins, so each label is srobbins – Steve Robbins Mar 14 '13 at 0:55
  • I will test this when I get back to work tomorrow. I have several Windows SMB shares I mount on my Mac, all with the volume name of "vol1". – bispymusic Mar 14 '13 at 2:49
  • As an alternate suggestion as well, you could create an Automator script (saved as an Application) that has two items in it: "Get Specified Servers" and "Connect to Servers". If your passwords are saved in Keychain, this may allow you to automate the mounting of all of them. And you could then place the Automator application in Login Items. – bispymusic Mar 14 '13 at 2:51
2

You are correct. Since both server volumes have the same name, Login Items will think you are trying to add the same exact shares to Login Items.

To get around this, create an Automator application that follows this basic pattern: enter image description here Then drop this Automator application into your Login Items. Every time that you login going forward it will run the script, thereby mounting each of your identically-named volumes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .