My macbook suddenly stopped showing USB flash drives in Finder when I plug them in.

I tried 3 different USB sticks - none work (worked just fine yesterday).

USB-ports work fine - I tested all three with an iPhone, iPad, my Nike+ device, even my usb-modem stick - everything works just fine. Except for the USB-storage devices...

The USB drives do not show up in the Disk Utility. The USB drives do not show up in the "System Report" (known as "System Profiler" in earlier versions of OSX). 1 times out of 10 they do show up as some weird "Composite device" there, but do not work.

I have Mac OS 10.7.5. I tried resetting NVRAM / PRAM - didn't help.

PS. the weird thing is that the drives do not show up under Boot Camp as well, when I'm on windows. So it's not just some drivers problem, but maybe firmware fault? My guess is - my Mac does not supply enough power to the USB ports when a USB drive is inserted? It's a hardware problem since the ports work fine with all other "non storage" devices.

  • Open Console and search for the term "USB". Do you see a message about them not receiving enough power, or any other messages related to USB? I have certainly seen power issues before with USB on a Mac. Does your iPhone charge or simply sync when plugged in? – bispymusic Mar 12 '13 at 15:37
  • The MacBook onboard keyboard and the onboard trackpad are also 'USB devices'. Do they still work? – CousinCocaine Sep 25 '13 at 9:06
  • What makes and models are the drives? When recognised (as a composite device or whatever): in Terminal, run diskutil list and include the output in your answer. Thanks. – Graham Perrin Sep 25 '13 at 15:49
  • 1
    If you can insert an bootable usb stick, reboot and hold down the alt key when booting. If your bootable stick is not shows - it is a firmware/hardware problem. If it shown and allows boot from the stick - problem is elsewhere - at higher level. (just make sure than the stick is REALLY bootable - best try it on another mac first, if you can). – jm666 Sep 28 '13 at 14:35

When "System Report" aka "System Profiler" does not list your USB devices, and Windows running from Boot Camp also does not list your USB devices and no power is supplied by your USB devices it is very likely that this is not a software issue.

Another way to see your connected USB devices with detailed information is to run

system_profiler SPUSBDataType

If the above fails and gives no satisfied output, it is very, very likely some of your internal hardware components are broken or disconnected.

When there are no problems with your other IO devices (e.g. firewire) it might be an internal cable that came lose, else I would suggest your south bridge is broken.

If you still think the power is the problem, try to use a powered-USB hub that will provide the juice needed for your peripherals. Or you can try to plug-in a low power consuming device like a USB mouse.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .