4

Two of our users have been getting this weird issue where their login to the computer seem to take "ages".

The issue seems to go away if you turn off FileVault.

However we need to keep FileVault on, but as this only effects a small number of users it seems like this is some specific issue with just their computers.

Info about the computers:

  • MacBook Pro (Retina) - Early 2013
  • Mac OS X 10.8.2
  • FileVault 2

Connected to Active Directory (Network Account Server)

  • Are your users connecting via VPN? If so, which type of VPN connection? Do you have any network drives mount on login? – bispymusic Mar 12 '13 at 15:24
  • No VPN, At worst WiFi connection or no network access at all. – vrklgn Mar 13 '13 at 8:52
  • Same problem... Any solutions other than "make sure the network is connected before turning your computer on"? – Jonathan S. Fisher Jul 7 '14 at 15:24
  • Same problem. We moved to exchange, I was on El Capitan. A short while later I enabled FileVault because I was travelling. I immediately had problems with debilitating slowness on the login screen as above (entering actual credentials, not booting). I upgraded to Sierra in a last ditch attempt to fix it. Ironically I could log in perfectly the first time after the update, and after a subsequent Sierra update. But any other time the problem remained. I just disabled FileVault and the problem has gone away. This is obviously not ideal. – Mark Nov 20 '16 at 22:44
1

Think I found an answer: https://jamfnation.jamfsoftware.com/discussion.html?id=6025

sudo defaults write /Library/Preferences/com.apple.loginwindow DSBindTimeout -int 8

Changes the bind timeout to 8 seconds. Our bind happens within 3-4 seconds over ethernet, so we figure double it and add an extra second should be enough for an absolutely unscientific unengineering-like guess.

  • This didn't work for me – Mark Nov 20 '16 at 22:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .