There is no pop up menu when I right click. I have set right button to secondary button as in the following picture.

Using ctrl+left click, there is a pop up menu so I can copy/paste selected or do some other tasks.

What I am doing wrong? I am using 10.6.8 on iMac.

enter image description here

  • Have you installed (or not properly uninstalled) some other pointing device drivers like USB Overdrive? – Lri Mar 11 '13 at 10:17
  • I don't think so. I have used external USB drives, that's all. – user565739 Mar 11 '13 at 10:39
  • have you tried a different mouse? – MattDMo Mar 11 '13 at 18:04
  • No, but I found the mouse is fine. Please my related question apple.stackexchange.com/questions/85043/… – user565739 Mar 11 '13 at 18:34

If indeed you have a Mighty Mouse as pictured in that screenshot, it's possible that the capitative sensors aren't properly detecting the right click action.

The most common cause of this was still having your left-click finger on the mouse, or resting very close, which I recall confused the sensors a bit. Try right clicking with only one finger touching the mouse and see if that helps. If not, it's possible that it's simply a hardware failure.

  • No. When a select some words, so it is highlighted by blue color. And then I right click above it, it just un-highlight the selected words. Left click do the same thing. – user565739 Mar 11 '13 at 12:12
  • That could still be that the right button is registering as left when your fingers are both down. See this article for some more suggestions. – robmathers Mar 11 '13 at 20:49
  • Finally, I just put the ball of the mouse on a white paper and roll it very very angry for a while, and now it works and I am not angry anymore..... – user565739 Mar 14 '13 at 8:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .