When a PDF is opened, its actual background color is often white. On Windows, several PDF viewers have the ability to set the background color to another one, which doesn't modify the PDF file itself. You can just think that it adds a virtual color when a file is opened by those software. But when you open the same file by other softwares, it still has white background.

I often need to read many articles (PDF format) a day, and white background make my eyes feel uncomfortable.

Does Preview have the same feature? Or any plugin to do this?


So Preview does not have this feature, but more on that in a moment.


I would strongly recommend you take a look at f.lux.

f.lux makes your computer screen look like the room you're in, all the time. When the sun sets, it makes your computer look like your indoor lights. In the morning, it makes things look like sunlight again.

f.lux will adjust (you can modify the strength) the colour of the whole screen to make it easier on your eyes. You can set it to be on all the time, or automatically come on at night time. People love it.

Now, back to your question...

Adobe Reader for Mac does support this. Once you install the 400MB app, you can change the background colour in Preferences (⌘ cmd + ,) > * Accessibility** . Check Replace Document Colours, and set the right colours you want.

screenshot of Adobe Reader accessibility preferences


You can change the background color in Skim (a popular and lightweight app for viewing, highlighting, annotating, and editing PDFs). Open up your document in Skim, then open up the (Apple) Script Editor (search script in the spotlight search), paste the following script in there and run it:

tell application "Skim"
    set theColor to choose color
    set page background color to theColor
end tell

This opens up the Skim color chooser from which you can choose your desired background color. Unfortunately the changes are not persistant. So for easier changes in future, save the script (the Script Editor's default saving location is iCloud), and then for subsequent changes all you have to do is to open the scirpt editor, double click the script, and run it. See Here for more details.

Please note that if you change the background color using the Skim UI, only the surrounding color changes, rather than the document's background color.

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Tetsujin Jan 4 '15 at 19:48
  • @Metallica : On doing that the background color changes to black, but how can I change the text color ? – Jaswin Apr 14 '16 at 5:45
  • Doesn't seem to work for image-based PDFs (e.g. scans). – Ariel Apr 2 '18 at 8:50
  • 1
    Not working for me with current version (Skim Version 1.4.38)... Did work with a previous version, though. – Neal Young Nov 27 '18 at 14:11
  • 1
    Not working for latest version (1.4.41) – alanwsx May 4 '19 at 1:26

Here's what I do, no coding, no plug in.

Click on tools, select annotation, then mask.

You should see a grey frame now. Adjust the size of the frame to let the gray area cover the whole page.


  • This does not work for multipage pdf – Madhur Ahuja Dec 10 '18 at 16:56

A more simple way to do it.

  • Open Terminal
  • copy and paste defaults write -app skim SKPageBackgroundColor -array 0.78 0.93 0.80 1
  • reopen Skim
  • This does not work. – EngineeredBrain Jul 19 '17 at 19:21
  • Skim now has a control in its Preferences for the background colour. – benwiggy Nov 3 '19 at 12:10

At least on El Captain (or even earlier release):

  1. Open Preview > Preference
  2. General > Windows background
  • 4
    I think that changes the background of the window, not the document itself. – Fang Jing Sep 12 '16 at 23:56

npm i -g serve && serve, open file in Chrome from http://localhost:5000, Chrome extension Dark Reader > enable dark for this domain

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .