2

I did a clean install of Mountain Lion 10.8.2 on my MacBook Pro. Now I am facing some problem while loggin into Facetime and Message (could not sign in please check your network connection and try again). In console I am getting this message.

apsd: Certificate not yet generated

3 Answers 3

1

A possible solution is to change your DNS server settings.

I had this problems for a while, and a friend too, and the solution that worked for us was just changing the DNS servers to Google's DNS.

To do this, go to System Preferences > Network > Advanced > DNS >

Then press the + button on the left below DNS Servers, and add both:

8.8.8.8

and

8.8.4.4

Hope this helps!

1
  • Thanks for replying but I already tried it, didn't help :(
    – Ankur Arya
    Mar 16, 2013 at 8:28
1

I also had this problem, and this fixed it for me.

Just open Terminal, and run these commands:

cd Library/Preferences
ls .GlobalPreferences.plist.*
rm .GlobalPreferences.plist.*
mv .GlobalPreferences.plist GlobalPreferences.plist.bak

After that, just reboot your Mac and FaceTime/iMessage should now work perfectly. Hope this helped!

SOURCE: http://xevio.us/blog/douglas/facetime-certificate-error-fixed-deleting-globalpreferencesplist

9
  • ls: .GlobalPreferences.plist.*: No such file or directory
    – Ankur Arya
    Mar 17, 2013 at 6:12
  • It did that for me as well, however the problem was still fixed. Run the entire script at once by copying and pasting it all into Terminal, then press enter on the last step to finish. Then restart your Mac - it still works. I believe the author of this script used the middle two lines to ensure all files are deleted. Mar 17, 2013 at 12:24
  • Thanks Faiz but still no luck. still getting apsd: Certificate not yet generated and failed to get client cert on attempt 4,will try in 60 seconds.
    – Ankur Arya
    Mar 17, 2013 at 14:54
  • Open Keychain Access and click Certificates. Delete any untrusted certificates. Does this help? Mar 17, 2013 at 17:15
  • 1
    Also, is your date/time synched with Apple's server? Go to System Preferences, click Date and Time, choose the Date & Time tab and check the 'Set date and time automatically' checkbox. Mar 17, 2013 at 17:17
1

I experienced this problem in 10.8.5 Messages caused by mistakenly entered filtering rules in LittleSnitch. After I disabled deny rules for the following services, the login problem went away: apsd, fpsaud, and ubd.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .