0

I allowed AppStore to apply the newest firmware update to my MacBook Pro, which seemed to work fine, until the final restart. At this point, the machine just shut down. I waited for quite a while, assuming it was doing something (despite no power LED) before trying to switch it on using the power button.

The machine now won't start. If I press the button, the screen does absolutely nothing, and the power led briefly turns on, and dims after about 5 secs. At the same time, my DVD drive attempts to power up, and continues trying to read for a rew seconds before dying as well.

I've tried the following:

  • Testing the mains charger, it was OK
  • Trying to start the machine with/without charger
  • Tried to reset the SMC, but nothing seemed to happen other than the same above
  • Burned DVD of firmware update for 1.7/1.6 and inserted into DVD. DVD took disc for 1.7, then won't give it back (and nothing else happened)

Suggestions welcome, and my thanks in advance.

3
  • Make an appointment with an Apple Genius at your local Apple Store. Yes, I know it's out of warranty, but bring it in anyway. They'll either help you restore it or quote you a repair price if there is hardware damage. – user10355 Mar 11 '13 at 6:07
  • Thanks cksum, was hoping to avoid this, only because I also replaced the hard drive and memory. Although this is looking increasingly like my only option – theZenPebble Mar 11 '13 at 16:37
  • It may be that one of your parts failed. If you still have the original RAM, try booting with it. If you can swap out the HDD and replace it with another one (the original), try that too. If that fails, then I'm afraid a trip is in order. Things like this are just really hard to diagnose and solve over the Internet I'm afraid. – user10355 Mar 11 '13 at 20:13
1

I had to perform the SMC reset twice after this exact thing happened just now. After the second reset, it booted and finished the firmware update.

1
  • Whilst this isn't exactly what I needed (I performed the reset more than twice), it's the closest to the solution. I was resetting the machine for the nth time, and the rubber foot dropped off, at the same time the machine came to life. I have no idea if these two things are related (I assume/hope dearly that they are not) but the machine has come back to life, and seems fine. – theZenPebble Mar 14 '13 at 1:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .