I have a couple of GMail accounts which I track on my iMac, iPhone, and iPad. On the iOS devices, both of the accounts are setup as Exchange accounts with Push delivery. I read that this is the recommended way to setup iOS with GMail and everything has been working flawlessly with this configuration for years.

A few days ago, the iOS devices stopped sync'ing properly. They receive all inbound emails immediately. However, if an email is read or deleted on my iMac, this isn't reflected on the iOS devices at all unless I force-quit the email app and restart it. It's getting really irritating because the iOS devices are constantly showing unread mail even when my inbox(es) are completely empty.

What happened? Does it have something to do with this latest iOS update (6.1.2)? The release notes said it had something to do with Exchange but I didn't read closely because technically, I don't use Exchange and I figured it didn't apply to me. Did they screw something up somehow? Shall I revert back to prior iOS version?

Any ideas appreciated.

  • 1
    I would recommend resetting up your Gmail accounts on your iOS devices. As in, deleting them out, and adding them back in. If you have 2-step verification enabled you will have to re-generate the codes, but as long as you have only 2-3 Gmail accounts, this isn't a big deal. I think you would find it very difficult, if not impossible to revert iOS versions. Also, can you force a sync (pull down to refresh), or will it not sync either way? Commented Mar 8, 2013 at 4:25
  • I had already tried adding/deleting the two email accounts. There's no two-step verification (??) so it was relatively painless, but no luck solving the problem. Can't force sync via pull-down refresh. Only force quitting the email app and restarting it causes the sync to take place. Commented Mar 8, 2013 at 15:26
  • Ouch. Too bad it wasn't something really simple. The 6.1.2 release note said it was fixing an Exchange bug that burned data on Verizon phones, IIRC. What about setting them up as actual Gmail accounts for now? If they are @gmail.com accounts, that should work. Unfortunately, you do lose push (which is a really nice feature as you know). My Exchange style accounts still work, but it's entirely possible this is indicative of a 6.1.2 bug. Commented Mar 8, 2013 at 16:15
  • To correct my previous comment... executing a pull-down refresh does trigger a proper sync. I guess the lesson learned in all of this is that these iOS updates shouldn't be installed unless they address a very specific problem that I'm facing. It seems like for every bug they fix, they introduce two or three new ones. Commented Mar 8, 2013 at 16:47
  • 1
    Honestly, I think that is fantastic. What is interesting is that I have never had Exchange-setup Gmail account push changes - only new emails. This is where the refresh time (Settings.app -> Fetch New Data -> Fetch) has always worked for me. Hopefully the next iOS update will fix that for you and get it working like it has before. Commented Mar 9, 2013 at 17:04

4 Answers 4


Go to mail, contacts, calendars>Fetch Data> check every 15 minutes!!
Took me a few minutes and found no one posting this fix!!


Google has shut down all gmail pushes to iOS devices as of Jan 30. If you device was setup prior to that date, you're grandfather'd in.

Personally, I'm looking at switching to outlook.com. It has full exchange support and it quit easy to move all contacts and emails from gmail to outlook.


What worked for me was to turn off the sync on the account. Then I went in and set up sync label by label. I did this because I noticed the trash folder was not set to sync, and I couldn't turn it on. With the sync off for the account, I was able to sync the trash folder. Now my deletes on the phone sync to gmail via the web.


Turning off 2-Step Verification will revert you back to push changes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .