Note: This question is how to send an Insert keypress to Microsoft Windows running directly on Apple hardware. This is not about how to use Insert in OS X or through OS X to Windows running in a VM. See here or here for non-Windows Q&A's.

Somehow in my code editor and command line I keep toggling the Insert key, but I'm not sure how. I can toggle it by clicking on OVR/INS in the status bar, but what is the key combo that I'm magically fat fingering?

  • Someone please help me and edit the question to make it clear that I'm asking about bare-metal (not VM, not remote desktop, not OS X in any way...) Windows on a MBP. I clearly don't know how to. – Nick T May 6 '15 at 22:32

11 Answers 11

up vote 80 down vote accepted

Apparently fn + return is the winner.

  • 10
    not on my hardware (I have an early 2013 MacBook Pro) running Mavericks. for me, Fn + Return just generates a return – ekkis Jul 28 '14 at 16:14
  • 1
    @ekkis if you're running Mavericks (or any other OS X version), this question does not apply. "How do I simulate the Insert key in Windows on a MacBook Pro?" – Nick T Sep 15 '14 at 19:14
  • 3
    This doesn't work on a 2014 macbook pro running Yosemite. This just doe a "return". – James Dec 31 '14 at 18:16
  • 4
    I have the same issue with MacBook Pro (Retina, 15-inch, Mid 2014). FN+Return does not work. – user109497 Jan 13 '15 at 19:33
  • 2
    Just not true. Does not work on a Macbook Pro Retina, 15-inch, Early 2013 Yosemite 10.10.3. Sends a "return." Tried Fn + Return, Fn + i, Fn + Ctrl + m, Fn + Ctrl + i. Fails in a Windows 7 client in a VM. Fails in a Windows game ported to Mac asking for Insert (Freespace 2 Open). Fails on a different MBP at home. – geoO May 6 '15 at 18:29

While running Midnight commander in terminal on MBP (OSX Yosemite) I use ctrl-T for simuating INS

The keycombination fn + i is resulting in the same as insert does on Windows.

  • This does not work in Windows; are you in OS X? – Nick T Jul 7 '14 at 19:12
  • 1
    I'm in OS X, this worked for me. Thanks :) – Srikanth Jeeva Oct 16 '14 at 17:49
  • Not every time, not my hardware, and so the answer needs to be edited to reflect on which Macs this works. See my comments in the other answers. – geoO May 6 '15 at 18:35
  • Doesn't work for me – Sleepyhead Oct 10 '17 at 10:31
  • No, this is not working. – Kornel Nov 6 '17 at 19:39

I have been able to find no way to do so, with a modern Macbook Pro. (The keyboard view only shows a minimal keyboard)

Apparently fn + return is the winner.

Not on newer Macs, that key combination is just 'enter' (instead of 'return').

  • 2
    Is that in Windows or OS X? My question was regarding Win – Nick T Apr 2 '13 at 19:17
  • @NickT, as per the other thread, Fn + Return evaluates to just Return on my hardware – ekkis Jul 28 '14 at 16:12
  • 1
    I think this has been changed in recent hardware. I am downvoting wrong answers and upvoting yours. If someone wants to make an answer that has a list of which Macs, running which version of the OS, and in what application (VM, Bootcamp) which key combination = Insert, well, that will get an upvote. This is an open question all over Google because of many varying Mac configurations. I've tried on 4 different Macs and gotten varying success. It doesn't help that there are easy key rebinding apps that have concealed the complexity of the issue. – geoO May 6 '15 at 18:33
  • Not at all. Crtl + Enter just behaves as Enter. – Kornel Nov 6 '17 at 19:37
  • @Kornel in 2013, with my then unibody macbook pro, this was tested as working. I can not speak for today's models -- I've moved back to thinkpads and linux. Also note the posting doesn't mention ctrl. – demure Nov 7 '17 at 21:09

I just wanted to point out, that you can map any key or key combination in OSX to any other key or key combination using Karabiner.

In my case, I'm using the following configuration to send Insert to Windows through TeamViewer, for example when running NVDA screen reader software (which heavily relies on key combinations using Insert) to test websites for accessibility.

<?xml version="1.0"?>
    <name>Fn + Ctrl-Left to Insert</name>
      __KeyToKey__KeyCode::CONTROL_L, ModifierFlag::FN,

This way, for example, I can send Insert+N (which opens the NVDA menu) by pressing Fn+Ctrl+N in OSX.

  • Excellent, thank you. I knew I could do it with Karabiner, but I wasn't overly keen to figure out their XML config. Thanks so very very much! – James T Snell Sep 12 '15 at 22:24
  • THIS is the actual right answer! – James T Snell Sep 12 '15 at 22:30
  • @Doc the answerer doesn't seem to be running Windows on their hardware, but remotely. Ask a separate question if you want this to be the "right answer" :P – Nick T Oct 26 '15 at 19:04
  • @NickT: Yup, I understand. I used this solution to help my mother who RDPs to a Windows box and needs an Insert key for her work. She uses it many many times per day, it works great. – James T Snell Oct 26 '15 at 19:28
  • I also run virtual machines using VMWare Fusion, so in some way I'm running Windows on my hardware (except its virtualised). – Joshua Muheim Oct 27 '15 at 8:18

the answer is Fn + m

however, to make it work:

  1. Run the On-Screen Keyboard (Windows 2012: Windows Key + C to bring up the charms, click Search, type "keyboard")
  2. Click on Options
  3. Turn on numeric key pad
  4. Make sure NumLock is turned off (so you can see the Ins key where the 0 would be)
  5. on the regular keyboard the "m" is where the 0 is, therefore Fn + m = Insert
  • by the same token, Fn + . = Del – ekkis Jul 23 '14 at 22:26
  • Are you kidding? Why would anyone go through that process instead of just fn + return for Insert, or fn + "delete" for Delete – Nick T Jul 23 '14 at 22:52
  • because that solution doesn't work for everyone (like me) – ekkis Jul 25 '14 at 17:29
  • I couldn't get your solution to work; what hardware and OS (8/Server 2012?) are you using? – Nick T Jul 25 '14 at 17:42
  • @NickT, I have a MBP (2.8GHz) running OSX 10.9.4 and I'm RDPing into Windows Server 2012 via the 8.0.7 client – ekkis Jul 28 '14 at 16:11

I'm using Apple Wirelss Keyboard model A1314 on an DELL XPS 13 laptop running Ubuntu 14.04 and for me, Fn+Shift+return key combination offers what shift+insert offers in Windows, which is paste.

option + command + i is the winner

fn+Enter works for me in Windows 8.1 in the BootCamp of a MacBook Pro

Other interesting key combinations:

  • fn+Delete: Delete next character (as opposed to Delete which deletes the previous character)
  • fn+Shift+F11: Print screen to clipboard
  • rightAlt+3: # symbol

I found many of them in

  • The OP specifies a MBP, the link to you cite states Fn + ENTER only works using an "Apple Keyboard with Numeric Keypad" and specifically shows NO entry for "Insert" under "Apple USB & Wireless keyboard" or "MacBook Pro keyboard" which is what the OP is using. – geoO May 6 '15 at 18:42

Given the diversity of options that sometimes work or not, I thought to try the Onscreen Keyboard that Windows has in it's "Ease of Access" menu. The OSK has an Insert key and it works fine after you select the relevant foreground window. Once done, close OSK and carry on as normal in your VM

fn + Enter - it's working on Windows 7 installed at MacBook Pro

  • Which MBP specifically? I'm trying to compile a list of Mac hardware/OS where this works. Apple support ( states that it does not work with a MBP keyboard, and I can't get Fn + Enter to work on my MBP. Did you use a Bluetooth or USB keyboard? Did you remap any keys using software? Which version of the Bootcamp drivers are you using? – geoO May 8 '15 at 15:30

protected by Tetsujin Dec 18 '15 at 7:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.