5

I just recently bought an album on iTunes and I have a weird problem. All of the songs (18 in all) except for one, play perfectly fine. When I try to play it, it says "This computer is not authorized to play "". Would you like to authorize it?" It prompts me to sign in with my Apple ID, which I did. Then it says "This computer is already authorized." I have no clue how to fix this! I've tried the steps outlined in iTunes: Missing folder or incorrect permissions may prevent authorization and iTunes repeatedly prompts to authorize computer to play iTunes Store purchases, but neither of them work. Any suggestions?

  • Still happens in latest version on iTunes; my content is deauthorized at random and I have to find the song, delete it and re-purchase from the iTunes store. – lonstar Aug 16 '15 at 15:29
5

In the end, deleting all the offending track and re-downloading it was the only thing that worked. Why I didn't think about this at first, I don't know, but it worked!

| improve this answer | |
1

Here's what worked for me:

1) Right click the album or song. The first option that appears is "Remove Download"

2) Click "Remove Download" and blue cloud icons should appear next to the song or songs.

3) Click the icon to download the song. The cloud icon should disappear after the song is downloaded.

4) Click on the song to make sure it plays. If there are more songs with the issue, repeat this process.

| improve this answer | |
  • This is correct! The downloads are old and so by re-downloading them the server can "authorize" them. – Melvin Jefferson Sep 29 '19 at 9:33
0

Maybe you could try uninstall the iTunes and then download and install the latest version, authorize again.

| improve this answer | |
  • I could, but then I lose my library... – daviesgeek Mar 4 '13 at 17:17
  • @daviesgeek Uninstalling iTunes would neither delete the media files nor the library's data files. – HairOfTheDog Mar 4 '13 at 17:21
  • Ok, maybe I'll try that then! – daviesgeek Mar 4 '13 at 20:46
0

I would recommend deauthorizing all your computers from iTunes. Go to the iTunes Store, and look for the Account link under Quick Links on the home page. Under Apple ID Summary, look for Computer Authorizations, then click on Deauthorize All. You'll need to reauthorize all the computers that use your account; though you may just have the one.

| improve this answer | |
  • Okay. I'd much rather do that than what Jolya suggested. Thanks – daviesgeek Mar 6 '13 at 18:13
  • I found the "Computer Authorizations", but there's no "Deauthorize All" button... – daviesgeek Mar 7 '13 at 0:15
0

The "deauthorize all" option will only show up if you have more than one computer authorized on your account. If you have only one computer authorized it can be deauthorized right from the "Store" menu. I had the exact same problem - what worked for me was to make sure the "iCloud download" column was checked and visible (right click in area where artist, name etc labels are and scroll down to click on "iCloud download"), a small icon with a cloud and an arrow were shown beside my song and clicking on that downloaded it from the cloud. I can play it now. I'm not sure why the file went to the cloud at all when I downloaded it - my computer is not connected in any way but I will have to further investigate that. I hope this helps!

| improve this answer | |
0

What worked for me was in iTunes, top right corner on click on down arrow, and then Account info, then manage devices in iCloud. This was very different from the authorised computers under STORE in itunes. Once I deauthorised all, I could then authorise my computer. Big thumbs up to Apple support for that solution, will try to get them to update their support pages with that fix.

| improve this answer | |
0

JUST found the solution to my nearly year long battle with iTunes and the: You are not authorized. You're already authorized issue. Just adding this to spread the word that Ctrl +b -> Edit -> Preferences -> Advanced -> Reset Cache worked for me.

Every time iTunes started it thought it was freshly installed and prompted me to go through the tour, set the default music player, and authorize (each time saying it was already authorized). It wasn't just one song, it was about 50% of my music and 100% of my movies. I had already tried- deauthorizing then authorizing, uninstalling, reinstalling, deleting that SC- folder and restarting -- nothing worked until I cleared the cache.

| improve this answer | |
0

Had same issue, had just downloaded an album but three of the tracks would not play, giving this 'authorise' error. As suggested deleted them, but to re-download them went to Account (top of screen), Purchased, and listed purchased tracks. A cloud symbol was next to those I had deleted, clicked this to re-download them, and they played normally.

| improve this answer | |
-2

De-authorize your computer and then re-authorize it, cured the authorization causality loop.

| improve this answer | |
  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the steps you provided will answer the question. Use sources from Apple or others to support your answer. See How to Answer on how to provide a quality answer. - From Review - – fsb Sep 10 '16 at 4:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .