4

I recently switched from Linux to Mac OS X, and one little tweak that didn't survive is disabling the blue highlight "glow" that Firefox adds to App Tabs when they have updates. Any idea how to do that?

I followed these instructions to disable it on Linux, but they don't work on Mac OS X. I have this in my ~/Library/Application Support/Firefox/Profiles/personal/chrome/userChrome.css file:

.tabbrowser-tab[pinned][titlechanged]:not([selected="true"]) {
    background-image: none !important;
    background: none !important;
}

...but no luck. Putting other CSS rules in that file does work though.

I'm on Firefox 19.0 on Mountain Lion (10.8.2).

1
  • It seems, I found correct place, but can't reproduce glow effect at all. Can you help me?
    – Eir Nym
    Mar 17, 2013 at 7:40

1 Answer 1

7
+50

Put one of these snippets in your userChrome.css file, depending on your Firefox version:

Firefox 69

Toggle toolkit.legacyUserProfileCustomizations.stylesheets to true in about:config as well as userChrome.css modification.

Firefox 29 (Australis)

.tabbrowser-tab[pinned][titlechanged]:not([selected="true"]) > .tab-stack > .tab-content {
  background-image: none !important;
}

Pre-29

#tabbrowser-tabs > .tabbrowser-tab > .tab-stack > .tab-background * {
    background: none !important;
}

Discovered by looking for [titlechanged] selectors in browser.css (chrome://browser/skin/browser.css).

  1. https://www.userchrome.org/how-create-userchrome-css.html
  2. https://bugzilla.mozilla.org/show_bug.cgi?id=1541233
4
  • i was able to use those to write a userChrome.css setting that works. i've added it to your answer; please accept that edit when you get a chance. thanks again!!!
    – ryan
    Mar 18, 2013 at 18:24
  • 1
    updated again to handle all parts of the glow. (some had still been showing for the last few firefox releases.)
    – ryan
    Jun 13, 2013 at 4:03
  • .tabbrowser-tab > .tab-stack > .tab-content[pinned][titlechanged]:not([visuallyselected="true"]) { as of FireFox 44 (at least)
    – Tim Morgan
    Mar 9, 2016 at 17:06
  • Had adapted this answer to .tab.pinned { background-image: none !important; } but it doesn't appear to work anymore as of FF 64.0.
    – Daniel
    Dec 15, 2018 at 19:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .