I have a brand new Memorex TravelDrive 64GB USB disk which is being troublesome.

It's formatted FAT16 on MBR, which is not so nice, and I'd like to put it on HFS+.

I've tried to do this through the Erase and Partition tabs in Disk Utility, as well as from the CLI in Terminal.app via a couple different methods:

$ diskutil partitionDisk disk4 1 GPT HFS+ newdisk R
$ diskutil eraseDisk HFS+ newdisk disk4

In those, disk4 represents the special device or disk identifier (i.e., /dev/disk4) and newdisk is the arbitrary name I'm giving the new volume on the disk.

In all cases, the process hangs trying to unmount the disk. I've done a bit of investigation, to no avail:

  1. Tailing the Disk Utility log while it's running (tail -f ~/Library/Logs/DiskUtility.log) doesn't provide any useful information. All I see is:

    Starting next Erase job: 6 with no options
    2013-03-03 00:51:57 -0500: Preparing to erase : “newdisk”
    2013-03-03 00:51:57 -0500:  Partition Scheme: GUID Partition Table
    2013-03-03 00:51:57 -0500:  1 volume will be created
    2013-03-03 00:51:57 -0500:      Name        : “newdisk”
    2013-03-03 00:51:57 -0500:      Size        : 63.92 GB
    2013-03-03 00:51:57 -0500:      File system : Mac OS Extended (Journaled)
    dmAsyncStartedForDisk for disk4 
    2013-03-03 00:35:30 -0500: Unmounting disk

    and it hangs there, thus having me need to "Stop Progress" from the Debug menu after 20 or 30 minutes.

  2. Trying to figure out if something has hold of the disk for some other purpose doesn't reveal anything either -- ps aux | grep fsck returns only one process:

    ryan        4967   1.0  0.0  2432768    588 s003  R+   12:57AM   0:00.00 grep fsck

Anyone have thoughts on how to figure out what's going on here?

  • You have a 64GB USB disk with a single MBR partition formatted as FAT and you want to make it a single GPT partition formatted as HFS+. Did I get it right?
    – duci9y
    Mar 3, 2013 at 6:36
  • Yes, that's exactly what I'm trying to do. It doesn't seem to want to get past the unmount. Mar 8, 2013 at 22:32
  • Try formatting it with fdisk as an MBR disk and then use Disk Utility on it. May be the factory-set FAT partition is causing problems.
    – duci9y
    Mar 9, 2013 at 5:42
  • 1
    It's always possible you have a bad USB FWIW, just throwing that in the mix, as the one answer suggests. I know it's a heresy to suggest this here, but will it format on a Windows machine?
    – JimLohse
    Jan 20, 2016 at 15:37
  • 1
    Years late with this comment, but I'd suspect a fake drive. How can a 64GB drive be FAT16? Test with the Fight Flash Fraud app, F3X (freeware)
    – Tetsujin
    Sep 22, 2016 at 18:48

2 Answers 2


You need to use /dev/disk4 in place of just disk 4 in your command. It should read like this

diskutil partitionDisk /dev/disk4 1 GPT HFS+ newdisk R

It sure looks like you have all the correct commands. Have you tested these media using Disk Utility or tried your commands on a USB drive you could stand to erase?

My suspicion is the storage you are using isn't 100% functional.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .