28

My girlfriend added Facebook to my Notification Center. I tried to set the alert style to none, and you can see the check mark to show items in Notification Center is deselected.

http://i.stack.imgur.com/qRaKV.png

I want it completely gone but don't know how else to configure things.

4
  • Have you tried signing out / deleting Facebook from the Mail, Contacts, Calendars system preference pane? Just select Facebook on the left and press - to delete the feed. After a reboot, you might try adding Facebook again and see if it's not sending notifications, but you might have to choose to remove that account if there is a bug in the controls. You're doing the correct steps in Notification center controls AFAIK.
    – bmike
    Mar 2, 2013 at 23:12
  • 1
    Same problem with the Hazel application. I've deleted the application, but it's still listed in the Notifications preferences! Very irritating.
    – Wildcard
    Sep 26, 2016 at 18:56
  • A very similar question on Stack Overflow, with some answers: Remove application from Notification Center. May 13, 2019 at 19:57
  • (Despite the similarity, I don’t suggest merging this question with the Stack Overflow one. The asker of that question wrote the app that they want to remove from the Notification Center, so answers that involve editing the app are valid there but not here.) May 13, 2019 at 19:57

9 Answers 9

29

Open Safari › Preferences › Notifications There you can remove objects permanently by selecting the notification you wish to delete and then either hitting the delete key or by using the remove button ('-') if it exists.

4
  • 2
    Not possible in Sierra, not listed there
    – powder366
    Apr 8, 2017 at 7:20
  • Thank you! This was the only thing that worked. All the other searches for removing notification app were showing useless stuff, like deleting the NotificationCenter .db file or setting alert style to 'None'.
    – Noon Time
    Nov 8, 2019 at 5:26
  • 1
    Works on Big Sur. Thank you!
    – Yan Pak
    Nov 25, 2020 at 17:31
  • This was driving me crazy! This solution worked for me too on Big Sur. Only thing to note is that the path to this is Open Safari › Preferences › Websites > Notifications then select the website name on the right and click the "Remove" button bottom left. Thanks.
    – Doug
    Jul 16, 2021 at 7:14
21

Highlight the desired app and hit delete

1
  • 2
    This is the answer! Note: delete, not backspace, as the latter does not work. This is strange, Apple! Tested on High Sierra… Nov 12, 2018 at 0:26
3

I had this problem too. Go to System Preferences > Internet Accounts . You can remove Facebook account from there and then it will no longer appear in the notification center at all

2

Go to Mail, Contact & Calendars and click on minus sign (-) after selecting Facebook on the left pane.

1
  • Actually I did that before asking the question. Is there anything else I can do? Mar 3, 2013 at 21:04
1

There's an answer found here that worked for me with an app I had uninstalled but was still in the notification center: MacRumors Forums: Remove app from "In Notification Center" list

In that forum thread, two users discover that there exists a folder /Users/<your-username>/Library/Application Support/NotificationCenter/. That folder contains a database file.

2
0

Just drag it down to Not in Notification Center list.

2
  • 1
    The App is already in the Not in Notification Center list.
    – IconDaemon
    Nov 21, 2014 at 15:50
  • Although technically wrong, I'm glad Bob tried to help because this answer helped me with a similar issue.
    – Dave
    Apr 2, 2015 at 14:29
0

For websites that added a Notification, you can remove it by going to Safari Preferences, to the "Websites" tab, then to the "Notifications" section. When you remove it from there, it automatically disappears from the Notifications prefpane.

0

You can remove these using Safari → Preferences → Websites → Notifications -> (Select the websites you wish to remove) → Remove.

While you are there, also consider unchecking Allow websites to ask for permission to send push notifications.

-2

Finder -> Go to floder -> ~/Library/LaunchAgents/ -> Delete the plist file related to notification -> Done.

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .