I used to vnc into my Mac mini (late 2012 model) with my MacBook Pro (mid 2011) before I enabled filevault2. Both macs are running mountain lion at this point. I can no longer screen share with my Mac mini. I can connect using ssh and afp but not vnc.

Is there a problem with FileVault disabling vnc? If not how can I trouble shoot this problem. Any tips?

1 Answer 1


I can confirm that FileVault 2 does not disable VNC client or service. I use encryption on all Macs and VNC between them frequently (both at home and at my F500 employer).

Can you be more specific about how it is failing? Do you see "Share Screen" option in Finder? Have you tried via Finder > Go > Connect to Server? Does it time out or give an error message?

  • This is the usually error message when trying to connect to the remote machine via Finder: "Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly." I have tried creating a vnc server with other 3rd party options (CotVNC, tight VNC, etc.) to no avail. I have also tried to connect via vnc through ssh bu that didn't work either. I have tried all of the normal routes as well. Mar 1, 2013 at 8:13
  • Here are a few recommendations, some less invasive than others: #1 Remove FileVault and test VNC again. If it works, try re-enabling and testing again. #2 Turn off Screen Sharing on remote Mac and enable Remote Management. This is used by ARD but controls Screen Sharing & VNC through a slightly different method. #3 Try doing a Mountain Lion Restore on the remote system (not a full wipe, just the default restore that puts a fresh OS on it and maintains user data). Let me know if any of these work!
    – bispymusic
    Mar 1, 2013 at 21:49
  • I finally had the chance to do some of what you mentioned. I turned off screensharing and ARD to no avail. Then I turned off filevault on the remote machine. It really didn't work either. I then tried to install a third-party vnc server. This worked for me most of the time, which in turn somehow started making the built in vnc service start working some of the time. I also tried some command line stuff as well (kickstart and even loading and unloading ARD (support.apple.com/kb/ht2370), seeing if anything would help) May 10, 2013 at 13:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .