4

I have F5 key bound to the show desktop shortcut in keyboard shortcuts. However when I press F5 on the keyboard (with fn on the built in keyboard, or with/without fn on the Apple wireless keyboard), nothing happens. If I try to bind it to anything else such as mission control or notification center, it just works. Any idea why?

enter image description here

4
  • Just tried it on my iMac w/ wireless keyboard. It works well with F5. Feb 28 '13 at 19:06
  • If you press the button 'Restore Defaults' and set it again to F5, does it work?
    – jaume
    Feb 28 '13 at 19:31
  • Tried Restoring Default. Unfortunately no effect. Even if I assign it to any other shortcut (F6, F1, control-Up), nothing works. The only that works is using gesture on touchpad.
    – Tony
    Mar 3 '13 at 20:51
  • Same issue with my computer, and it just started in last few weeks. I did change my keyboard shortcuts recently for Mission Control; change my coincide with this (Show Desktop is still defaulted to F11) Apr 23 '14 at 12:30
3

Create a test user account on your Mac. Adjust this same setting. See if it works. If it does, I recommend moving the following file on your user account to the Trash:

~/Library/Preferences/com.apple.symbolichotkeys.plist

Then log off & back on. This will reset all Keyboard Shortcut settings back to default. If it doesn't fix it or causes other issues, simply drag the .plist file back to its former location.

1
  • 1
    Switching to another user indeed works. I will try trashing the symbolichotkeys.plist next time I log off and report back.
    – Tony
    Mar 3 '13 at 21:06
0

I just got help from Apple support about this so I'm dropping this in case someone else hits that problem:

  1. Remove all entries from System Preferences -> Users & Groups -> Login Items
  2. Restart NVRAM/PRAM during system boot

The conclusion is: some app might be messing up the settings, affecting this shortcut. 🤷🏻‍♂️ I've found solutions online with deleting some files from Library/Preferences, but the problem kept coming back after rebooting my Mac. The 2-step solution described above fixes it permanently 👌🏻

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .