I'm having an issue with both my iPhone and iPad - both on iOS 6.1.2 (actually not sure if it's that on iPad, latest iOS regardless).

I connect to my WPA2 enabled Wifi network at home (tried WPA also) and it requests the password. I enter the password and can browse as normal connected to the Wifi network. If the phone or iPad sleeps however, I have no Wifi connectivity upon waking. I need to go into settings, select the Wifi network again and once more reenter a password for it. Essentially it seems as though the network settings have no persistence.

  • I have tried resetting "all settings" back to default.
  • I have tried resetting "network settings".
  • I had no issue previous to upgrading to iOS6.
  • I have tried changing encryption methods on the router.

Modem is a Netgear DGN2000.

I'm not sure anyone will be able to offer many suggestions, as really since the iPhone and iPad is so restrictive in what you can do with it, by nature it's hard to trouble shoot effectively.

migrated from superuser.com Feb 28 '13 at 11:50

This question came from our site for computer enthusiasts and power users.


There are issues with iOS6 and some Netgear products.

This is taken from http://kb.netgear.com/app/answers/detail/a_id/21865 which is directly linked to the products page on the Netgear site.

There have been widespread reports of wireless connection and speed problems with devices using Apple's newly-released iOS 6 connecting to NETGEAR products. The problems that you are experiencing may be due to a recent upgrade of the Apple iOS 6. While the nature and extent of the iOS 6 and Wi-Fi connectivity issues are unknown, NETGEAR will do our best to continue to monitor the updates from Apple and continue to work with our customers to ensure that we can help provide support and work-arounds (when possible) to get your devices connect properly.

There are several other pages and forums linked from there, I don't have enough time (or a way to test) which of these actually fixes the issue.

If you find one of these resolves your problem, please post the solution back here for others.

You must log in to answer this question.