I started to experience problems with my iPhone that seem to be related to the dock connector.

Upon plugging my iPhone into my (officially supported) car stereo, I started to get the message "This accessory is not supported by iPhone" on the screen. Didn't think much of it as I only use it for charging purposes, and that still worked so I ignored it. Then I bought a small ANT+ dongle, which is a little accessory you plug into the dock connector to allow your phone to receive data from various health/fitness devices like heart rate monitor, and cycle sensors etc. It produces the same error message every time I plug it in, and the apps that use the dongle will not recognise it.

The dongle does officially support my hardware and OS level. I've checked that it is not broken by plugging it into an iPhone 5, an iPad 3 and an iPod of some description, none of which showed the error. The supported apps find the device on the iPad, the iPhone 5 does not have the apps installed but offers to do so as soon as I plug it in, so I know the dongle is working correctly.

In addition to the above, when nothing is plugged into the dock connector, it still occassionally thinks that something is, resulting in a muted phone. When it's in this state I am not able to hear anything or change any volume settings (music playback or ringer volume) with the physical keys. Going into the Music app shows that it thinks it's outputting the music to the dock connector.

Why is this accessory not working on my iPhone, and how can I get it working? What causes my iPhone to think that it's docked when it isn't?

7 Answers 7


This commonly occurs when there is an issue with your dock connector. It is likely dirty, obstructed in some way, or possibly even broken with a bent pin or something. Very often this is not apparent, because with 30 pins to play with, chances are most of the time you only need the ones for charging and USB data transfer, leaving the rest unused such that you will not notice if they start working sub optimally.

There are 3 ways I would try to fix this, in order of most likely to fix:

Clear it out

Your first step is to check for any obvious blockage. If you have a can of compressed air, you can try to blow any debris out. If you don't, then using a fine non metallic scraper (a plastic toothpick is ideal, a wooden one may leave small fibers behind) carefully clean out what you can - even if it looks clean you will be surprised how much crap and fluff you can scrape out. Take care to blow any debris out of the phone, and not into it - i.e. hold it upright and get at it from underneath, don't sit it upside down and work from the top

Clean it up

If there is no obvious obstruction then the problem may be more subtle, a coating on one or more of the pins that is preventing a neat conductive contact, or is grounding a pin against another one for example - perhaps there has been some contact with a liquid in the past etc. You need to clean the pins to get rid of this. You will need a couple of things things - 1) some cleaning agent, 2) a lint free cloth/piece of sponge, or an old toothbrush.

For a cleaning agent, 99% isopropyl is perfect, but if you don't have that kicking around you could try a very small quantity of the neatest and purest alcoholic drink you have in the house - I've used Vodka which is by and large 50/50 alcohol and water. Don't use anything flavoured or anything that it likely to have anything other than alcohol and water in it! Especially sugars or salt!.

Using a very small amount of your cleaning agent, and keeping the phone upright so any drips fall out, and not into the phone, lightly brush or wipe the dock connector, taking care not to be rough enough to disturb the pins out of alignment. I've used a small piece of synthetic sponge and prodded it about with the same toothpick I used earlier.

Hit it

If this doesn't work, then the issue could still be a physical obstruction, although it may be beyond the dock connector and more internal. Short of taking the phone to bits, there is not a lot you can do, and whilst you cannot clean the inside, you can try to dislodge anything that's stuck by using a combination of lightly tapping the phone on all 4 sides whilst playing about with the vibrate functions for alarms etc.

Using the first 2 methods above I solved the "Accessory not supported problem", but still had the intermittent docking issue.

Assuming I could not fix that one, I went to turn on Vibrate alerts (which I had previously turned off) as a workaround, only to find that after playing with all the vibrate "tones" etc it magically fixed itself!

  • Note 1 It's possible that the issue is not with the connector on your phone, but on your device/cable - you can try all the above on the cable end too if doing it on your phone does not yield results.
  • Note 2 If your device is failing to charge, or will only charge from a certain cable or dock, then the same fix potentially applies.

I had this same issue. I'm pretty sure from being in a damp pocket during a snowy 5k.
Here's what I did:
Turn the phone off
I used a concealer makeup brush dipped in alcohol to brush down the connector (while I was at it I also did the usb cord i use on my imac and the headphone jack).
Did a hard restart (hold down the power button and the home button for like 5 secs).
Hopefully this isn't a temporary fix!


@stuffe came up with a couple of correct solutions based on traditional wisdom, but failed to realize the depth to which Apple will go to obfuscate problems from the user. It appears that there is a software setpoint for current (or power since the voltage is supposed to be the fixed) below which this state is triggered.

The message: "This accessory may not be supported", is due to insufficient power.

I am sure there is/was an Apple engineer could tell you exactly what current threshold triggers it (probable reasoning is adverse affect on battery life), but that is really irrelevant. Here are some things that you can do to correct it.

  1. Clean connections. Crud on connectors act as an insulator, reducing the amount of current flow.
  2. If its a usb cable, plug it in to something with a higher current (amps/milliamps) or power (watts/milliwatts) rating.*
  3. Turn off, power saving features that may reduce power to usb ports. (if it stops after X minutes this is probably the reason)
  4. Make sure your usb adapter outputs sufficient Volts (indicated by it only charging to XX% before you get the message)
  5. Use a usb port closer to your laptop's the power supply (They often handle more current than easier to access ones)
  6. If you have one, you can try a powered usb hub (good ones are better with high powered devices)
  7. If none of that works, try a known working cable from a someone.
  8. If that doesn't work you may have an issue with the connector in the phone itself.

    • Usb power adapters should have the design voltage and current printed on them; however, this is the "design" rating. Not all of them actually perform to spec in real life and it is not uncommon for components to weaken or fail over time, but still have some output.


I have an ASUS laptop running Linux and it has an easy to access usb port on the right hand side near the front that doesn't output quite enough power. Combined with a bit of connector corrosion, the only way it would charge was if I held it down fairly tightly on the charging base. As soon as I would let go, I would get "This accessory may not be supported". Simply switching it to the usb port near my power connector (in a less convenient location) was sufficient. This tells me that it likely has nothing to do with any "device" specifics and since I have no iApps installed, those are ruled out too. The only difference is the power output. I will probably eventually need to clean my connections, but for now I'm good.

TODO: Write a polite letter to Apple requesting error messages that actually mean something.... It's probably in errno.h and strerror.h depending on how far they have gotten from their BSD roots (just add something like ELOWPWR and "This accessory has insufficient power for charging." respectively).

TODO: Get a cheap charger from the Dollar Tree, expose the wire and use a potentiometer and ammeter to determine an approximate current threshold that triggers the message inoperable charging state.


On a jailbroken device, follow these instructions from Battlesnake5 on reddit:

Using iFile, go to /System/Library/LaunchDaemons and move com.apple.iapd.plist somewhere safe. This disables the service that works with accessories from starting, so when you reboot it should work fine.


I have an iPhone 4S and I had the issue where it stopped connecting to any plg in device. I tried the cleaning, which did no harm, but then I messed around with the vibrate settings and it cleared immediately.

  • What might "messing around with the vibrate settings" entail if someone wanted to try that to solve their issue?
    – bmike
    Commented Jul 18, 2013 at 10:47

In order for the line out audio to work for an iPhone 5 or 5s dock, make sure you have iOS 7. I had iOS 6 running on the iPhone 5 and the line out audio would not work.


The same thing was happening to me so I just powered it off and back on and it was fixed so try that first.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .