I bought a brand new Mid-2012 MacBook Pro 13" from Apple. Ever since I've had it, it's had this quirky bug where headphones are only recognized if they're plugged in before the computer is woken up: the computer has to be either turned off or put to sleep every time I want to plug in my headphones. I called Apple Support and went through all the usual stuff and some not-so-usual stuff, but the problem still persists. I, along with multiple tech support guys from Apple, finally just concluded it was a hardware issue. I never bothered to take it into the store to get fixed, and the problem never went away (no surprise there).

Today, after living with this and doing nothing about it for months, I installed a fresh copy of Windows 7 Enterprise using BootCamp, and in Windows, headphones work perfectly all the time. I've just been living with this issue since I've had a workaround, but this makes me think there must be some way of making the jack work properly in OS X, too.

Any ideas on what could be causing this problem or how to fix it? What would be different about Windows 7 that would make it act differently?

Here's what I've already tried:

  • Resetting the PRAM and SMC
  • Ensuring that no weird audio drivers or services were installed (the Apple Support guy and I went through my /Library and ~/Library with a fine-tooth comb)
  • Re-installing the OS fresh (in fact, since then, I've changed hard drives and installed fresh a second time)
  • Cleaning out the headphone jack itself
  • Using a different set of headphones (any of them that use the 1/8th inch jack don't work in OS X but do in Windows; Bluetooth and USB headphones work fine)
  • Ensuring that everything is attached correctly inside the MBP (no frayed wires, no loose connections, etc.)
  • Is the headphone check recognized when headphones are not working (Apple Logo in the menu -> About this Mac -> more info -> system report -> Audio)? I think there is still a chance of a hardware failure. Maybe the Windows drivers just connect differently to the port (?).
    – cyphorious
    Commented Feb 26, 2013 at 9:00
  • I'm pretty sure you've checked this a thousand times, but could you nevertheless please provide a screenshot of your sound output preferences (I'm interested in the list of devices).
    – cyphorious
    Commented Feb 26, 2013 at 9:11
  • And one last question (sorry for the flood of comments): Have you already played around with the "Audio and Midi Setup")? This will may only help if your headphones a REALLY not recognized, meaning that if you plug them in you will still get sound output of the internal speakers and not just having everything "muted".
    – cyphorious
    Commented Feb 26, 2013 at 9:15
  • Yes, the headphone jack shows up in the system report, even though it doesn't work.
    – ahruss
    Commented Feb 26, 2013 at 21:23
  • @cyphorious Here is what the out preferences looks like. It doesn't change at all when headphones are plugged in. (i.imgur.com/DRAKGTh.png) I guess I didn't make that clear in my question. The headphones are completely unrecognized when I plug them in. Absolutely nothing changes. The internal speakers don't mute, the volume doesn't change, nothing. It's as if I hadn't plugged them in. They are REALLY not recognized. What do you recommend changing in the Audio MIDI Setup?
    – ahruss
    Commented Feb 26, 2013 at 21:32

2 Answers 2


It's entirely likely you have a situation where the drivers on Windows are not detecting a faulty hardware condition and thus continue to send signal to the copper ports. Your Mac may be sending the audio to the TOSlink (optical) portion of the jack.

See this other question for details and a similar answer by @chico on his experience getting around this hardware failure by using different OS / drivers.


I have experience with the same issue and think it's Apple fault in how OS X handles the dual function of its audio output. My solution was to install Ubuntu, it doesn't mute it anymore.

Since using Ubuntu 13.04 now on my macbook pro early 2011, it never suffers from the infamous headphone jack problem. Removing the headphones, the internal speakers work, plug it in, the headphone works.

Here're some articles that explain what's up with the headphone jack, and the root cause of this behavior:

On OS X, it just doesn't work. If I dare plugging in the headphones, I know that when I take it out, internal speakers will stop working, they will be muted, and not come back after a while. I've stopped plugging stuff in and out trying to make it work.

I just installed a new OS that works. I suspect Ubuntu, maybe, just ignores all the stuff about the dual mode of the headphone jack.

Hardware resolutions for this problem span from cleaning the output to replacing the logic board. IMO, its Apple fault to produce such a delicate hardware device and not provide means for controlling the dual-mode of the audio output through software, which, as can be seen, can be done.

  • I only just saw this answer. I keep seeing people talking about the same issue you're describing, but I haven't found anyone who has the issue I've been having. When I plug in headphones with the computer awake nothing changes. The audio doesn't mute. Nothing. It's as if I hadn't done anything. If I plug them in before waking it, they work perfectly until I unplug them, but when I unplug them, the computer doesn't mute; it just goes back to the internal speakers and I can't get it to go back to headphones when I plug them back in.
    – ahruss
    Commented Jan 5, 2014 at 3:12
  • @ahruss I think it's somewhat related behavior sadly, like for the same hardware design reasons I tell.
    – oblitum
    Commented Jan 5, 2014 at 3:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .