I've had to buy an older Intel Core Duo Macbook to replace a stolen one. I've installed Aperture 2.1 from an old disc. It won't open, I get a message saying something like: "You can't use this version of Aperture with this version of Mac OS X. You have Aperture 2.1." I'm running 10.6.8.

I rang Apple, the reply was 'it won't run on your machine, there's nothing you can do. But I can make it work for you it will cost £35.' I declined that offer. I have an Imac running Snow Leopard with Aperture 2.1 running OK.

I've tried to install Rosetta (to see if that would open Aperture)from my Snow Leopard install disc. I get a message telling me the installation was successful, but I can't find it anywhere on my hard drive. Any ideas?

  • Did you try running Aperture again after installing Rosetta? Rosetta itself is not an application so there isn't anything to start specifically.
    – nohillside
    Feb 24 '13 at 14:49
  • Also, try right-clicking Aperture, clicking Get Info and then checking 'Run in Rosetta'. That should tell OS X to run the application in PPC mode. Feb 24 '13 at 15:49

Running Aperture under Rosetta will be a painful experience. It will not be swift. Note also that working with different versions of aperture on a common library is a good way to get corruption. Apple doesn't recommend running aperture on non-local disks either. I've tried it, and while pictures are present, seaches return far too few results.

If you bought Aperture through the App Store, you should be able to unlist your stolen mac at the store, and install it on your newer mac for no charge. If the current old mac book won't run the current aperture version, then I think that there are older versions on the Mac web site.

Finally, once you authorize the new laptop on the app store, you can just share the apps folder from your iMac, and drag and drop the Aperture.app folder from the older iMac to your laptop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .