1

I restored my iPod touch 1G and when it rebooted after completing restore, it got stuck showing the iTunes logo.

I tried two different methods of exiting the recovery mode as explained at

How To Fix Recovery Mode Loop OR iTunes Logo on iPhone, iPad and iPod Touch

I even tried via Snowbreeze as explained at

How To Jailbreak Using Sn0wbreeze v2.9

but these didn't work for me.

Does anyone have any ideas on how to fix this?

  • Was it a jailbroken iPod? – daviesgeek Feb 27 '13 at 7:14
  • Actually, I don't have idea whether it is a jailbroken one. I just tried to restore my friend's iTouch. – hsuk Feb 27 '13 at 7:18

You must log in to answer this question.

protected by grg May 27 '15 at 14:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged .