Suddenly no site in the UK will open in Safari (10.8.2 OS/6.0.2 Safari): BBC.co.uk, virgin.co.uk, apple.co.uk, amazon.co.uk, bobsyeruncle.co.uk, etc - every UK site is unavailable. Safari generates a "Failed to Open Page / Safari cannot connect to server" error. It's as if the entire range of servers in the UK have been denied.

Yet if I use Chrome or Firefox, no problem; UK sites pop open without issue, so it's likely not a system issue (etc/hosts). If I open a different user, Safari opens the UK site fine - the problem only seems to affect this one account. Unfortunately it's my work account.

What I've done (nothing has worked):

  • Checked proxies, none on
  • Uninstalled Safari Extentions
  • Removed Safari preferences
  • Fixed disk permissions
  • Flushed DNS caches
  • Removed Safari files from the ~/Library/Saved Application State folder
  • Removed Safari folder from ~/Library/

Okay - I give up. What have I missed?

  • All sites you mention are reachable for me, so you might work on traceroute to see where on your route to the internet things are getting blocked. For instance apple.co.uk goes to San Jose as part of Apple's servers there. Of course much of it might be stored on CDN servers in the UK to speed delivery to UK customers, but you might widen your search / edit the question to be more of a networking issue.
    – bmike
    Commented Feb 24, 2013 at 0:09
  • Unfortunately it wasn't anything to do with the way the system gets data - other users and apps had no problem, just this one user using this one app. (Even though it's solved, I wanted to respond partly in thanks and also to keep the logic of how to diagnose in the future clear - the answer is below)
    – Holland
    Commented Feb 24, 2013 at 8:24

1 Answer 1


It ended-up being even more simple: Little Snitch somehow blocked all domains within the UK range. I didn't know it could do that! I discovered it by rebooting in safe mode and discovering it did work, then removing anything running on boot.

  • 1
    Good process. I've seen that program catch people unawares so many times. Blocking DHCP so the WiFi doesn't work, blocking system updates, third party apps, etc… Glad it's sorted out for you.
    – bmike
    Commented Feb 24, 2013 at 15:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .