Issue: I try to launch MAMP Pro, enter my system password then it sits there trying to connect to MySQL. This has been running fine previously.

Background: I'm running OSX v10.8.2 and Path Finder crashed, followed by Skype. I did a restart, both those apps were then fine, but MAMP Pro fails to launch.

I've updated MAMP Pro to latest version (v2.1.2), and Googled for solutions, nothing seems to resolve it.

Console shows this:

18/02/2013 18:35:22.335 coreservicesd[64]: Application App:"System Preferences" [ 0x0/0x23023] @ 0x0x7fde9ad13050 tried to be brought forward, but isn't in fPermittedFrontASNs ( ( ASN:0x0-0x22022:) ), so denying.

18/02/2013 18:35:22.335 WindowServer[102]: [cps/setfront] Failed setting the front application to System Preferences, psn 0x0-0x23023, securitySessionID=0x186a5, err=-13066

18/02/2013 18:35:22.418 MAMP PRO[272]: * -[__NSCFString substringFromIndex:]: Range or index out of bounds

MySQL log is empty.

I run: ps aux | grep mysqld in terminal (as suggested on numerous sites as a solution to MAMP Pro not starting MySQL), it lists one entry, but the PID continually increases and I can't kill the process via the name mysqld.

I've used Cocktail to purge memory cache and rebuild launch Services database.

I've also tried booting into Safe mode, then restarting (another suggested solution).

Any help would be greatly appreciated!

  • MAMP can be a real pain when it messes up. I would be curious if going to "File > Reset To Factory Settings > (do one and test, then maybe the other?)" would work for you? Commented Feb 18, 2013 at 20:05
  • Alas it's dimmed out and won't let me. Reset to Factory Settings expands to a sub-menu with "Development" and "Live" - these items are dimmed. It seems that most of the controls are disabled while the MySQL is continually spinning and trying to start. Commented Feb 18, 2013 at 20:14
  • Try quitting the program, then reopening it. Before starting Apache and MySQL do the reset. Commented Feb 18, 2013 at 20:26
  • Don't get a chance - even when not entering in my password and clicking cancel. it just kicks off immediately trying to start. There's nothing under preferences to prevent this. Commented Feb 18, 2013 at 20:31
  • Are you sure this checkbox is disabled? i.sstatic.net/FNX5W.png Commented Feb 18, 2013 at 20:36

1 Answer 1


Due to trying to get my local server up and running again, I installed and got working XAMPP, which then had a knock on effect of allowing MAMP Pro to display a decent error message (instead of continually working) and allow the options on the interface to be active again. MySQL was running but Apache couldn't launch. Also, although I could change the settings on the MAMP interface, none would save. looking at permissions and ownership, the app and files were owned by root (but not sure that had any refection on the issue).

@bassplayer7 gave me pointers to the uninstaller (something I didn't know existed), which due to permissions couldn't actually do anything. So I found these excellent instructions: https://stackoverflow.com/questions/11855247/mamp-pro-restore-root-user-uninstall Which cleaned it off completely.

I then did a system restart, re-installed MAMP Pro completely fresh, and it all worked first time. Albeit without any databases, hosts or settings.

You do have backups, right?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .