18

I opened GarageBand for the first time, to find that most of the loops required me to download the Apple Loops from Software Update. I agreed to this.

The App Store opened and gave me the option to install the update from Updates - I clicked Install and waited for the download to complete. It did, and then the installation began.

About half an hour later, the update is stuck on (Installing - Calculating...) This doesn't seem normal - the last time I installed the Loops, they were done in about ten minutes.

Force quitting and re-opening the App Store doesn't help, nor does a reboot. When I open the App Store, the update is still at the same process.

Is there anything that I could do to get the update to finish installing?

Here is a screenshot of the App Store in this state: The App Store in the state that I have described.

  • 1
    Four years after this Question was first posted, and the problem still exists in the latest OS X. Is Apple not listening ? – Mike Gledhill May 7 '17 at 7:10
21

In an act of desperation, I managed to fix the issue by:

  • Deleting /Library/Updates
  • Doing

    sudo defaults delete /Library/Preferences/com.apple.SoftwareUpdate.plist RecommendedUpdates
    sudo defaults delete /Library/Preferences/com.apple.SoftwareUpdate.plist DidRegisterLocalUpdates
    

    in a Terminal session

  • Restarting the Mac

The update is re-downloading now.

Interestingly, before I tested these steps, I found the update ready to install in /Library/Updates, however when I tried to install the PKG file, Installer claimed that another installation needed to finish (?). Deleting it and restarting fixed the problem.

  • 1
    Simply deleting /Library/Updates & restarting worked for me – Jon Jul 2 '15 at 16:29
4

Try deleting the cache located here:

~/Library/Caches/com.apple.SoftwareUpdate/

And the prefrences plist, here:

~/Library/Preferences/com.apple.SoftwareUpdate.plist

And start the application again. It should have flushed whatever updates that got stuck.

  • 1
    That didn't work. I deleted the Caches file (and /Library/Preferences/com.apple.SoftwareUpdate since there wasn't one in ~/Library/Preferences) and opened MAS. However, when I clicked Update, the update restarted again from Installing - Calculating. – Faiz Saleem Feb 18 '13 at 13:17
  • For me, removing ~/Library/Caches/com.apple.appstore/ worked. – Kousik Nandy Sep 14 '16 at 18:38
4

This happened to me after updating to the Developer beta of macOS Sierra. For me, the following solution helped.

Delete the downloaded updates:

sudo rm /Library/Updates

Kill the software update daemon:

sudo killall -9 softwareupdated

An additional note to analyze AppStore / softwareupdate problems is probably using the Console app or tail to have a look at /var/log/install.log.

2

Related to Emil's answer, I just wanted to add that I had a similar problem updating xcode. Simply clearing the cache and restarting App Store worked for me.

rm -rf ~/Library/Caches/com.apple.SoftwareUpdate/
  • This and sudo killall -9 softwareupdated worked for me. – smileBot Mar 22 '17 at 2:12
2

I have encountered this issue a couple of times, lastly while trying to install Microsoft Word from the Apple Mac Store. The following steps solved the problem for me:

  1. Close the Apple Mac Store COMPLETELY.
  2. Wipe the contents of the App Store cache folders. To do so, enter the following in your command line:
sudo rm -R $TMPDIR../C/com.apple.appstore/*
sudo rm -R ~/Library/Caches/com.apple.appstore/*
sudo rm -R /Library/Updates/*
  1. Kill all the processes shown in the Activity Monitor being listed when searching for ‘store’:

App Store process deletion

  1. Delete your App Store Preferences and Cookies:
sudo rm -R ~/Library/Preferences/com.apple.appstore.plist
sudo rm -R ~/Library/Preferences/com.apple.storeagent.plist
sudo rm -R ~/Library/Cookies/com.apple.appstore.binarycookies

And that's it, just start your App Store normally, and retry to install your app.

P.D.: A reboot may be needed.
P.D.: Don't freak out if the RMs say these files/folders do NOT exist and therefore they can't be deleted, you just are where you wanted to be already
P.D.: I know, I know, some of these commands do not need SUDO rights, but it doesn't hurt to using them either

0

Had a very similar problem to this - updates stuck on the 'Checking for Updates' spinning icon. Reboot failed to fix problem.

Because I am a newbie, much of what was said above seemed difficult, so I thought I'd just try the one thing I could actually find on my machine, which was to delete:

~/Library/Preferences/com.apple.SoftwareUpdate.pIist.plist

This step alone seemed to fix things for me.

  • Files not found on Mojave, but these might be the new relevant files: ~/Library/Preferences/com.apple.appstored.plist ~/Library/Preferences/com.apple.appstored.commerce.plist – Simon B. Mar 6 at 14:46
-1

I had this problem and I quit the App Store, used Activity Monitor to kill the softwareupdated process, then restarted the App Store and I was able to download again.

  • This is the same as previous answers and should've probably just been a comment to the other answer(s) and not an answer by itself. – fsb Mar 21 '17 at 23:41
  • No it isn't -- all the other answers involve going into the Terminal to run commands. This solution just involves opening Activity Monitor. The outcome is the same but it's a more accessible way to do it for most users. – Derick Mar 22 '17 at 19:12
  • 1
    It's the same answer with a different way of doing it. This should've been a comment or edit to the existing answers, not a new answer. – fsb Mar 22 '17 at 19:21
-2

just go to store option and click on reload page

-2

An additional note to analyze App Store / software update problems is probably using the Console app or tail to have a look at

/var/log/install.log

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .