I recently upgraded my macbook pro 2008 (not unibody, running 10.6.8) to mountain lion. Directly after the upgrade finished the machine ran smoothly. But after a reboot it does not boot at all (no gray display, but noise from fan and hard drive) and does not react to any keyboard input (so no SMC/NVRAM/PRAM reset, no Target Mode no Recovery etc). After some research I came to the point that I could not do anything but giving to a apple for repair, but I am still curious to understand, which component could have failed when upgrading.

So the only possible component could be the EFI firmware, which is responsible for the pre boot sequence, and hence it must have been damaged during an EFI upgrade, or is not compatible to my 3rd party ram, which worked perfectly in snow leopard. I tried to reinstall the system by extracting the hard drive and reinstalling the system, but this did not change anything. So where is the EFI firmware stored and is it somehow possible to access it, with no running system, and then is it possible to restore an older version?


It was not the RAM.

2 Answers 2


If you can successfully start your Mac from a Mac OS X DVD take a look at this: http://pubmem.wordpress.com/2011/04/09/flash-efi-firmware-update-manually-on-a-macbook-51/, especially comment 54 and follow-ups.

It explains how to manually flash the EFI firmware:

  1. Download the EFI Firmware update from Apple. This link lists EFI and SMC firmware updates. You will need the exact model identifier of your Mac.

  2. Unpack the firmware pkg using unpkg. You will need access to a Mac for this, as unpkg only runs on OS X. You need the file with extension scap.

  3. Start your Mac from a DVD and select Utilities>Terminal.

    Now comes the difficult part. You need to run this:

    sudo bless -mount / -firmware /path/to/your/firmware.scap

    It is unclear to me whether / is the right path (as asked in comment 59) or if you can even access the internal harddisk when booting from a DVD. You may have to plug in an external drive and copy the scap file there... You will have to figure it out for yourself.

    Alternatively, you can try:

    sudo bless -device /dev/disk1 -firmware /path/to/your/firmware.scap
  4. Restart. The Mac should flash the EFI firmware.

Disclaimer: Be aware that I couldn't test any of this so I'm giving the following information as a hint in the hope that it is useful.


To answer your question, on my macbook, the EFI is installed under /efi/EFI/APPLE/EXTENSIONS/Firmware.scap under my /dev/sda1 device.

I'm using a linux live cd. I have mounted /dev/sda1

Hope that helps..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .