The Problem

My problem is that I have manually mounted a NFS network share on my Mac and that now the system keeps on trying to remount it and doing so it displays an annoying focused popup telling: "There was a problem connecting to the server ...". If I close it, it is coming back several minutes later, and so on!

I have rebooted the Mac but I was greating by the popup once logged back in.

The Question

How can I tell my Mac to stop trying to mount the NFS share and forget it?

The Context

Recently, I was trying to do some benchmarking for my home server (HP MicroServer with NAS4Free or Fedora) to find the proper configuration set.

As the main client of this home server would be my Mac, I did the test from the Mac and mounted the NFS share using:
mount -t nfs -o tcp,nfsvers=4 ip:/path ~/Projects/mnt

It did not work, so I switched back to NFSv3:
mount -t nfs -o tcp,nfsvers=3 ip:/path ~/Projects/mnt

At the end of the test, I turned off the server before unmounting the share, which I did not care much as there is nothing yet important on this server. However, OS X complained and ask me to disconnect the drive or ignore and I disconnected it. But several minutes later I got the popup.

I did many investigations:

  • boot in safe mode: I don't have the popup
  • login a another user: I do have the popup
  • login holding down shift: I do have the popup
  • deinstalling or deconfiguring TimeMachine, SpotLight, CrashPlan, Dropbox, etc.: I happen to have been in a state where for several hours I had no popup
  • I tried reinstalling one by one, 1st TimeMachine, then SpotLight and CrashPlan. I rebooted between each and no popup. Then Dropbox and the popup appeared more or less at the end of the installation (cohincidence?). I removed Dropbox again but to my surprise I still have the popup. So it is perhaps one of the 3 previous app/services.

I have raised the question in a forum thread at Apple, but so far no solution. I then decided to turn to the StackExchange community for words of wisdom.

  • Have you tried mounting the NFS filesystem again and unmounting it cleanly with umount?
    – jaume
    Feb 18, 2013 at 20:54
  • @jaume Sorry for the late answer. Yes, I did that successfully, but the popup came back. In addition, if I mount the file system again, do unmount but let the NFS server up and running, after several minutes the mount is back!
    – Huygens
    Feb 24, 2013 at 15:03
  • Did you ever solve this problem? We are suffering from the same thing.
    – Mike Boers
    May 4, 2015 at 23:57
  • 1
    I managed to track ours down to the firewall preferences file. After several layers of encoding, there was a reference to an executable on the NFS. I guess it was trying to mount it periodically to check something...
    – Mike Boers
    May 7, 2015 at 17:35
  • 1
    Grepping the whole disk revealed nothing, so we started isolating parts we thought it could be. Moving the whole /Library/Preferences out of the way stopped the problem. It turned into a binary search of which particular file in there was causing it. A quick check showed it to be one of the ~20 that get generated when missing. Another 7 or 8 swaps and reboots narrowed onto the culprit. It ended up being /Library/Preferences/com.apple.alf.plist, and it took decoding nested binary plists (and perhaps some hex and base64) to finally find a reference to the mount.
    – Mike Boers
    May 8, 2015 at 15:22


You must log in to answer this question.

Browse other questions tagged .