15

I have an issue using the Apple Thunderbolt Display. I have a Dell XPS laptop with Windows 8 where I connect to the display over Thunderbolt, but every time I try to listen to some music or video, the sound comes from the screen, not from my laptop, even if I plug headphones into the laptop. How can I solve this problem? I want to work using my laptop and the screen but I want to redirect the sound to my headphones. Is this possible?

21

In Windows, you can typically choose a different output-source using this approach:

For switching outputs, try this:
Right click on the speaker icon in the tray. Choose "playback devices". Select from the list of playback devices (speakers, hdmi, usb headset,) (the device you want) Choose "Set Default" Your audio output will instantly switch Source

For quick access to this, you can download this application.

Applicable to OS X users:
You should be able to see the earphones in the music menu. Hold down Alt while clicking the Audio-icon in the menubar. There you can switch between the different audio devices, like the external screen and the earphones.

This can also be done from System Prefrences -> Sound and the tab Output.

  • It's impossible I am using Windows 8 – Dimitri Feb 15 '13 at 15:24
  • Oh, sorry. I'll see if I can find a solution that works there as well. – Emil Feb 15 '13 at 15:28
  • 6
    On OS X, you can also hold Alt and tap one of the three volume buttons on the keyboard. It'll open Sound Preferences. – Tyler Wayne Feb 15 '13 at 16:38
14

For those seeing this in OS X instead of Windows, there is a separate sound output selection box for "Sound Effects". Make sure to select Headphones.

enter image description here

  • 1
    Argh, how obscure is that! This was it. Many thanks! – Johannes Overmann Nov 8 '17 at 8:47
0

FYI I had a very similar problem. It was happening on Skype calls even when I had all the audio settings set to headphones. However, I then discovered that Skype has it's own preferences, and they were over-riding the computer settings and choosing the display audio.

I changed the Skype settings to "built-in" input and output (which seems counterintuitive because actually it was going to and from my earphones which I had plugged into the laptop!) Anyway, that fixed it and now I can make Skype calls using my earphone with mic!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .