I'm on a Mid 2012 MBP with Mountain Lion. I recently enabled FileVault on my boot SSD drive as well as encrypted my other hard drive I put into the optical bay. So far, so good.

However, each time I boot my desktop background reverts back to the default "galaxy" background that shipped with my MBP. Both my boot and secondary drive have their passwords stored in the keychain, so after logging in OSX should be able to see my background image.

I've tried placing the image on my primary and secondary drive but neither made a difference.

Is there some sort of trick I'm missing to get my own custom background image to stick after a reboot? I've even tried changing to a different default background image that ships with Mountain Lion, but even that reverted back to the default galaxy image.

Any Ideas?

1 Answer 1


This almost always has to do with corruption in the ~/Library since I've seen this come and go well before FileVault 2 came out.

Have you tried making a second user account and testing if the problem persists for a new user account?

If not, you'll need to poke into the ~/Library/Preferences folder, sort by date and see which files get updated when you change the desktop background and drag those preference files to the trash. (don't erase trash just yet in case you drag too many or the wrong preferences to trash).

Reboot and test - still not deleting the files. Once you think you've isolated the files (or file) where desktop pictures is stored, make a note of the file and empty the trash and the time.

That way if something else messes up, you can restore that file or resume the process of clearing selective preference files.

  • 1
    Thanks for the reply and for pointing me in the right direction. Just to add to what you mentioned, I had to delete the following file "~/Library/Preferences/com.apple.Desktop.plist". After doing that, I logged out and back in, changed my wallpaper, then logged out and back in again. Now after rebooting, my wallpaper stays at what I had set it to previously. Looks like the previous Desktop.plist file got corrupted or cached somehow. Thank you again! Feb 15, 2013 at 22:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .