When trying to convert or resize a dmg image I get the error:

hdiutil: convert failed Resource Temporarily Unavailable error


hdiutil: resize: failed. Resource temporarily unavailable (35).

(hdiutil error code 35).


The problem appears to happen when you unmount the image using umount.

Remount the image (either using hdiutil attach or just double click the image) and use the command hdiutil detach it again. This will unmount and eject the image.

hdiutil detach /Volumes/<your image>
  • 1
    The mounted images still appear in "Disk Utility" when you can remove them. – Stefano Palazzo Sep 20 '15 at 1:07
  • I used 'hdiutil info" found the /dev then "hdiutil detach /dev/disk2". That way you don't have to remount the volume. – drudru Mar 29 '18 at 22:29
  • This is it! I tried to use umount /Volumes/<your image>/ but it only unmount the image but still seeing the Apple read/write Media in Disk Utility... – Richard Fu Aug 20 '19 at 1:34

Another possibility is that the disk image is still mounted (from previous work on it). In this case, just select the eject icon.

Afterwards, the hdiutil convert worked great.


In my case something was trying to access the image. What finally worked:

sudo lsof | grep ~/Unix.sparsebundle/
sudo kill -9 889
resize -size 100g ~/Unix.sparsebundle/

restart your machine and it run it again it should work.

  • We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed. – Tetsujin May 22 '17 at 8:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .