I have a problem with a 15" MacBook Pro (2011, OSX 10.7.5): After being repaired due to a water damage recently, the sound was just working fine. Some days later the audio device in the status bar turned gray and the MacBook didn't play any audio anymore.

After having tried several approaches to solve the problem (e.g. https://discussions.apple.com/thread/1736638?start=345&tstart=0)

So I repaired HDD permissions and deleted ~Library/Preferences/com.apple.BezelServices.plist in normal and safe-mode of OSX. After a restart the speaker icon is highlighted again and sound was available again.

But another restart later it didn't work again. Now the approach mentioned before also didn't solve it anymore. As the soundcard was working fine temporarly I'm guessing it's just a software issue.

How can I come closer to a solution?

  • 2
    Is this problem specific for your user account or does this happen on other user accounts as well? You can make a new account and check if the problem persists. Commented Feb 11, 2013 at 23:56
  • Did not check that. Since reseting the PRAM helped, do you still think it can be account specific?
    – david
    Commented Feb 13, 2013 at 18:57
  • No clue. Making a new user account and testing if the audio problem persist will not take much time, so you can try it easily. Commented Feb 13, 2013 at 19:27

2 Answers 2


I've resolved this before (grey icon, no sound) by resetting the PRAM.

  1. Turn off your Mac
  2. Turn on your Mac
  3. Hold Down Cmd-Opt-P-R
  4. Keep Holding until you have heard the startup sound twice

Apple Support Document HT1379

  • solved it! thanks a lot! Curious why/how this is interconnected with the "BezelServices.plist", which also solved it temporarly.
    – david
    Commented Feb 12, 2013 at 1:15
  • Another restart later, the friend I checked the MacBook for told me, that it's the same problem again.
    – david
    Commented Feb 13, 2013 at 18:56
  • Hmm. I'm out of ideas then I'm afraid. Commented Feb 15, 2013 at 1:45

If resetting the PRAM doesn't work, you may try installing the latest Combo Update, like this one:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .