5

When syncing music to an iPhone, iTunes give you the option to drag individual tracks to a section labeled "Manually Added Songs" to add them to the device (as opposed to adding all tracks of an artist, genre or album). The "Manually Added Songs" section not only contains tracks "cherry-picked" in iTunes itself, but it will also contain tracks the were added within the device itself after your last sync (for example, by using the iOS version of iTunes to re-download a prior purchase).

This feature is behaving strangely for me: Tracks I downloaded manually from within the device a long time ago, continue to appear in "Manually Added Songs", even after I have manually deleted them from the device and even after I manually deleted them from the "Manually Added Songs" list itself (to avoid those songs being re-sent to the device on the next sync).

Essentially, this odd set of tracks (a few songs from album A, a few songs from album B, etc) continues to magically re-appear on the "Manually Added Songs" list regardless of what I do. The only way to not get these tracks sent to my device is to manually clear the "Manually Added Songs" list every time before I sync my device. This is clearly not the way this feature is supposed to work--sync should "trump" what's on the device, so once the "Manually Added Songs" list is cleared, that should clear those songs for good.

After complete re-installs of iTunes, iOS, OS X (for reasons not having to do with this problem), this problem persists even across two different phones. The one constant element is that we are dealing with the same iTunes (XML) library file. I would like to keep this file because of the play stats and whatnot, so if anybody can point me in the right direction (including hacking the iTunes library file), I would be ever grateful... I am tired of listening to those same songs! :P

2

I had the exact same problem with my iphone and itunes account. I would remove the manually added songs but whenever I synced they magically re-appeared. It took me some time but I figured it out eventually. If you go to your itunes library and untick the unwanted albums/tracks and THEN remove the manually added songs and hit apply, all the unwanted songs are removed from the device.

  • I appreciate the use of the words "and THEN" in your answer. Reading it that way made me realize that the option to 'only sync tracks that are checked' trumps the manually added songs list. Thanks. – Christian Correa Mar 6 '13 at 14:53
2

When you delete songs on an iPod (or other iOS device), they get copied back the next time you sync with iTunes. This makes no sense, of course, but that's the way it works. (It correctly does not re-sync apps you delete, most of the time.) The only way around it is to un-sync the tracks - make sure they are not selected in the Music tab, or are not in any playlists, or uncheck the tracks and choose the Only sync checked songs and videos options. Or you can manually sync music to the iOS device, but that may not be what you want.

  • I've tried to manually un-sync from iTunes, as you suggest. Normally, this would have worked. However, the problem I am having is it doesn't work anymore. Let's say I un-sync/un-check the twelve or so "problem" tracks and select new tracks. What is happening is that iTunes will always send to the device the new tracks plus the same twelve or so "problem" tracks. They refuse to go away, no matter what I do. It's very, very odd. It's only those twelve or so "problem" tracks. Everything else that I sync/un-sync manually works as you would expect. – Christian Correa Feb 15 '13 at 15:25
  • Try removing those tracks from your iTunes library, syncing, then re-adding them. – Kirk McElhearn Feb 19 '13 at 6:36
2

I took the longest time trying to figure this out, but finally came to a solution I hadn't seen in any of my research, so I thought I'd better share.

I'm on iOS 10 and haven't been able to toggle iCloud music on my iPhone, which I thought was where the problem was coming from, but it isn't. The solution is actually fairly simple:

First, on your iPhone, go to Settings>Music and select "downloaded music". Find the songs that keep showing up in the "manually added" section and delete them (or if you're like me, delete all the songs so you can start fresh).

Then, on the computer, remove all of the "manually added" songs. Sync again, and the songs stay off!

It's finally taken off the songs that I'd initially bought on the phone but only wanted parts of (like a movie soundtrack that I'd only wanted the songs from, and not the instrumentals).

I hope this is helpful to anyone else with the same problem.

(Note to any responses: I have no plans on returning to this page now that I've found a solution, so anything directed toward me will go unanswered).

0

Amazingly, removing the song from iTunes, syncing, verifying the song is removed from the phone, then adding the song back to iTunes, puts it back in the "Mannually add" list and adds it back to the iPhone. Really bizarre.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .