18

I have a weird problem on my 2011 MacBook Pro 15" running OS X 10.8.2.

Every now and then - say every two days - the system starts to ignore most of the keys I press for 2-3 minutes. It's like processing of keystrokes becomes incredibly slow. If I wait for ten seconds between each key, what I type is processed completely; otherwise kys wl b msng rndomly.

The system is not overloaded in any way when this happens. I'm usually writing something and this comes out of the blue.

Has anybody experienced the same, or could point me to some resources? I'm having a hard time coming up with a good Google query for this problem.

It is possible this was introduced by the 10.8 upgrade but I'm not 100% sure.

I managed to run top while this occurred again and the only thing that was runnng that usually isn't is Google's ksfetch. Will post more info if I catch it again.

  • 1
    have you tried reading the system log and finding if at that time happens something weird? and are you having that when in the Mac locally or remotely? (this happens to me remotely and sometimes when the mac is in a lot of stress). Thirdly, have you had the luck to have the activity monitor open when that happens, and see what may be causing that? Finally, has that happened to you always, or recently? (this would mean an app/launch daemon or similar could be the reason) – jackJoe Feb 9 '13 at 11:32
  • I second @jackjoe's recommendation. You can access the system log files by opening the Console app. (Type Console into Spotlight). If you open it, you will see a list of messages scrolling in real time. Keep it open, and have a look at the messages from just before this happens. – daviewales Feb 9 '13 at 13:09
  • 1
    @davie neat, will do and report back if I see something, thanks! – Pekka 웃 Feb 9 '13 at 13:56
  • Have you considered this to be a hardware issue? .. If you plug in an external USB keyboard, does the same issue occur at the same rate as the onboard? – adamrmcd Feb 9 '13 at 21:31
  • 1
    I am having exactly this problem, at exactly the same sort of rate (every two days or so, lasting 2-3 minutes) on exactly the same machine/OS. Weird. It's definitely not a hardware problem with the keyboard, because (a) it just lasts for a few minutes, and (b) there's a delay of ~1 second between pressing a key and seeing the character appear on the screen, and it seems that any other keystrokes during that delay are lost. @Pekka웃 did you find anything from the logs? – callum Feb 15 '13 at 13:42
4

There can be two reasons: software or hardware.

Software

This is most likely caused by the CPU being overloaded, so the kernel is throttled. That means only number of samples that are processed for a specific period to avoid overheating to prevent the crash.

To confirm that, run the following command in Terminal:

sudo fs_usage | grep -v 0.00

which should show something like:

THROTTLED  0.015030   kernel_task
...
THROTTLED  0.019601   coreduetd
THROTTLED  0.031014   kernel_task 
...
THROTTLED  0.014947   kernel_task

which means your kernel being throttled which may result in such unexpected behaviour (see also: Why kernel may be throttled?).

I had this problem when my system was eating t letter (for all the apps) and CPU sensors (in iStat) were over 90˚

To solve the problem, check the above command fs_usage and kill unnecessary processes. If it's web browser with too many tabs and a lot of ads and JS scripts in the background, close unnecessary tabs.

There is also a chance that it's caused by I/O throughput (disk access) and your storage (e.g. SSD) may be reaching its lifespan.

Hardware

If keystrokes are eaten consistently (like the same letter over and over again), this could be physical keyboard issue.

Before blame the hardware, you should try to:

If that won't work, you should arrange appointment at a Genius Bar.

For temporary workaround, see: How to deal with non-working key on the keyboard?

  • Cool. The problem hasn't reappeared since but I'll be looking for these if it happens again! – Pekka 웃 Jun 20 '16 at 11:34
  • 1
    I had this problem today and every second day and as result it's eating t letter quiet often for all apps. I believe it's overheating (on iStat it's showing over 90˚), because when the system works normally it works fine. The only part I don't understand why it's always eating t in my case. – kenorb Jun 20 '16 at 12:13
  • I've the same issue again, but this time r is eaten, but this this it's all the time, even after restart, so I believe this time it's a hardware issue. – kenorb Sep 16 '16 at 16:37
  • 1
    This happened to me, but only during the regular login screen. The keyboard worked fine in Recover Mode. Resetting NVRAM fixed it. – Ian Dunn Jun 29 at 19:23
2

FWIW: I'm having the same problem on my late-2011 11" MacBook Air. Every now and then some of the characters on the keyboard will simply stop responding.

My current theory is that it is a problem with overheating, because it only happens when using the laptop keyboard (and never with an external keyboard) and it only happens when the laptop is actually on my lap and never when it is on a desk or table or other flat surface with adequate ventilation.

  • Let's see whether somebody else can confirm your theory about the overheating. – nohillside Jun 16 '13 at 7:37
  • 1
    Mine is doing it without any overheating. (Retina, 15-inch, Early 2013) – KARASZI István Jul 24 '13 at 9:24
1

The internal keyboard is actually on USB. This suggests something else is hogging the USB. On my Retina MBP the other thing on that bus is the Bluetooth controller.

  1. Any other USB peripherals? iPad or iPhone connected?

  2. Anything hooked up on Bluetooth? Mouse perhaps?

  3. Any errors for either of the above in Console? Any other high frequency errors?

  4. Go to System Preferences -> Accessibility -> Keyboard and confirm that Sticky Keys and Slow Keys are off.

There was a spate of reports of similar problems around 2009 which I think were fixed by a Keyboard Firmware upgrade, but that should be bundled with 10.8. Sorry I can't find a conclusive answer in this case.

  • 1
    Interesting. I think I have observed this with no USB devices connected, but I'll keep an eye on it. – Pekka 웃 Aug 13 '13 at 12:32
1

Had the same problem - MacBook Air keyboard eating letters, mainly "ertyuio". Especially at login.... After looking for many solutions, one had worked:

  1. Install any new keyboard via System preferences > Keyboard > Input sources.
  2. Restart and delete the keyboard you've just installed, if not needed.

Worked like a charm! Hope it will do the same for you!

1

We have a late '09 iMac with a USB Aluminum keyboard that had been working fine until a few days ago. Then it started to lose random keystrokes.

Some experiments this morning finally revealed the problem/solution:

After a reboot (to get out of Target Drive mode) the Aluminum keyboard (ALkb) didn't register at all, though a spare Bluetooth kb (BTkb) worked fine. After re-plugging ALkb into a powered USB hub, it worked, but after a while we noticed it dropped keys. A different USB kb, from an older Mac Pro (MPkb), behaved the same way, though this one did work plugged directly into the iMac's leftmost (from the back) USB port.

Surprisingly, the ALkb did register and work when plugged into the iMac's rightmost USB port, though it still dropped keys.

The BTkb didn't drop any keys.

On a hunch I unplugged the Firewire 800 cable from the back of the iMac, even though it was inactive (not communicating with the attached Mac Pro), and suddenly both ALkb and MPkb worked without dropping keys. In addition, the ALkb now worked plugged directly into the iMac's leftmost USB port (the middle two ports were being used).

At least in my case, the inactive but plugged-in Firewire 800 cable somehow interfered with the proper functioning of the iMac's USB ports. So the admonition to unplug all unneeded cables is well-based.

1

I found that the keyboard trick mentioned by Pablo worked for me sometimes.However, it take a little longer (and interrupts my typing flow) to execute. The problem seems to still come back for me.

Another faster, temporary trick, is holding down all the bad keys FGHJK for a few seconds and then letting up. For some reason, pushing them down together and then letting up (and then maybe quickly toggling those keys until I get a response) will cause them to work again long enough for me to finish the sentence. Someetimes I can get a response as soon as I lift up. I suspect it has something to do with the keyboard buffer for those keys filling up.

I also have the onscreen keyboard installed (Keyboard-->Show Keyboard and Emoji in Menu Bar).

If the problem happens too frequently, I then can explore the longer term keyboard install/uninstall trick. However, because it requires a reboot I usually just plug in an external keyboard.

0

I experience this issue on macbook pro 2015 with macos sierra 10.12.1. It happens few times a day. Occasionally some keyboard characters are eaten, and sometimes the force (deeper) click on touchpad is not working and also multifinger gestures are not working. Then it can get even worse so that the mouse pointer stops moving at all. Sometimes the OS is able to recover from the behaviour after 2-3 minutes, other times I have to hard reboot the macbook.

In the sudo fs_usage | grep "THROTTLED" I can see many different processes being throttled, but CPU is well below 100% all the time.

I disabled Spotlight indexing and also tried sudo sysctl debug.lowpri_throttle_enabled=0, but the problem keeps emerging.

update: so few hours later after one reboot the built-in touchpad and keyboard were not detected by OS at all. this suggest I actually face a hardware issue (possible the internal connection cable has some problem).

  • 1
    This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Mark Nov 10 '16 at 12:46
  • Mark, I confirm my post is not an answer and I would love to add my experience as a comment - but I was not allowed to do that due to the rules of this site (I do not have 50 reputation points). honestly I do not understand such rule. – Peter Nov 10 '16 at 19:07
  • Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. – fsb Nov 10 '16 at 19:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .