When I downloaded an application (e.g. RubyMine) and transfered it to the Applications folder, the application wont start (nothing happens). It is not limited to the Applications folder, it appears for every directory I unpack the downloaded app (out of the .dmg).

When I type open RubyMine.app in the Terminal, I get:

LSOpenURLsWithRole() failed with error -10658 for the file /Applications/RubyMine.app.

And it happens with more apps then only RubyMine.

What can I do about this? At the beginning i was asked to allow the startup of the downloaded app, but now this appears every time.

  • It looks like this only happens to Java programs, but I can't say that for sure.
    – Appleshell
    Feb 7 '13 at 5:15

This seems to be a problem with permissions in the bundle itself. Usually the execution flag doesn't get carried over from the DMG image.

Try, for the sake of curiosity to set the execution flag like this:

chmod +x /Applications/RubyMine.app/Contents/MacOS/<name of the app>

Note: replace <name of the app> with the name of the app (it will probably be "rubymine", but I don't have that app to confirm the exact name of the binary.

If you're in doubt, right click on RubyMine.app, do a "Show Package Contents" and navigate to Contents/MacOS/ folder and see what's in there. Perform the above command (chmod +x) on that file and try again.

I think it should be:

chmod +x /Applications/RubyMine.app/Contents/MacOS/rubymine

update: I've downloaded RubyMine and the above command will work, however, for what is worth, I've got to say that mine had the execution flag so I didn't have any problem with it. Have you checked?

  • Glad to hear it Adam! Feb 8 '13 at 0:54
  • Currently, I'm having the problem WITH +x being set for everyone.
    – bot47
    May 6 '14 at 21:33
  • What worked for me was running chmod -R 777 /Applications/RubyMine.app (on the root of the app folder).
    – Joe Bane
    Sep 25 '15 at 11:14
  • still not working for filezilla (base) mona@goku:~/Downloads$ ls /Applications/FileZilla.app/Contents/MacOS/filezilla -rwxr-xr-x@ 1 mona admin 14797696 Dec 23 09:52 /Applications/FileZilla.app/Contents/MacOS/filezilla (base) mona@goku:~/Downloads$ chmod +x /Applications/FileZilla.app/Contents/MacOS/filezilla (base) mona@goku:~/Downloads$ ls /Applications/FileZilla.app/Contents/MacOS/ -rwxr-xr-x@ 1 mona admin 14797696 Dec 23 09:52 filezilla
    – Mona Jalal
    Jan 22 '20 at 4:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .