I have purchased an app which didn't download successfully. I deleted the installer and tried to install it again from the Mac AppStore but the download button says "Installed".

I also still have the app icon in my Launch Pad with the download progress indicator on it.

I'm aware of the option + click on the "Installed" button and on the Purchases button, but neither works.

How can I reset this download process to enable me to download the app again?

  • 1
    Not sure this works, but have you tried deleting the app with something like AppCleaner and then re-downloading it?
    – FLY
    Commented Feb 6, 2013 at 15:33

3 Answers 3


Answering my own question. I enabled the debug menu and then selected Reset Application, restarted the App Store and now the Download button shows up again.

To enable the debug menu, open Terminal and run

defaults write com.apple.appstore ShowDebugMenu -bool true
  • Sorry, your steps are 1. Enabled debug menu via Terminal, 2. Reset Application, 3. Restart App Store. I'm very unclear on Step 2. What exactly are you doing there?
    – Daniel
    Commented Oct 26, 2016 at 22:18
  • I answered my own question as well. The terminal command is supposed to activate a special Debug menu at the top of the screen along with all the standard windows like Edit, Store, Window, and Help. First of all, after sending the terminal command, you must restart the AppStore app for the menu to appear. Then in the Debug menu is an option for Reset Application.
    – Daniel
    Commented Oct 26, 2016 at 22:34
  • That said, this procedure wasn't working for me. The Debug menu wasn't appearing at all. Turns out it is because you have to issue the terminal command as the currently logged in user. In retrospect this makes sense, but I figured it was a global setting and was issuing the command as sudo (I always work on my machine as a limited user). It turns out this is a per-user application setting, so I just needed to issue the command as my limited user in order to get the menu to show up. This probably won't be relevant to most, since most people (foolishly) use their computer as admin.
    – Daniel
    Commented Oct 26, 2016 at 22:36
  • 5
    Unfortunately, this seems to no longer work with macOS 10.12 Sierra.
    – donut
    Commented May 5, 2017 at 17:22

First, make sure that you do not have a copy of that app on another hard drive that is mounted.

Next delete the icon from Launch Pad. It works like iOS where you click and hold on the icon until they start jiggling and then click the X button to delete it.

Quit and restart the Mac App Store.

Now you should see that it is available to download in the Mac App Store.

  • Clicking the x on the jiggling icon did nothing. It just stayed there.
    – Hesham
    Commented Feb 6, 2013 at 18:13
  • Mark's first step is important. Try emptying your trash if one is in the trash. If the "app" you want is a macOS installer and it is partially installed on some other partition, erase that partition. Commented Aug 7, 2016 at 0:45

I had this because a previous version of the app was still on the drive. I was trying to re-load Windows Phone Connector 8, had to delete both WPC8 and an old WPC7 i had on the drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .