Trying to access a remote FreeNAS box, with AFP sharing set up. (AFP works fine over the LAN, just not over WAN.)

From a remote location, if I go to Finder and Go>Connect to Server then enter afp://myserver.com, I get prompted for username & password, and then am presented with list of shares, just as over LAN.

However, when I choose a share, there's a little spinner in the bottom of the window; it spins for a few seconds, and then my machine is OUT COLD. I.e., frozen, halted ... not black screen, but NOTHING works except moving the cursor around. Cannot Apple-Option-Escape, cannot Apple-Tab, cannot click anything. Only option is hard reboot.

I tried this from both a MacPro running 10.7.4, and MacBookPro running 10.6.8, and had the same result.

On the FreeNAS side, it's a FIOS connection, using a Verizon MI424WR-GEN2 modem, where I forwarded port 548 (TCP & UDP) to the FreeNAS server. (Obviously I'm getting through fine, since I'm being prompted to log in and getting the list of shares.)

I'm 96% sure this DID work before we switched to FIOS over there ... when we had DSL.

I checked Console but didn't see anything that seemed relevant.

  • If you're getting this behavior on all Macs, it's likely something to do with the FreeNAS or routing end. Are you all updated and configured correctly? Have you checked your FiOS router settings (assuming you're using their modem/router combo)? – sofly Feb 6 '13 at 8:47
  • Strange ... if I use the static IP address, i.e., afp://, it works! If I use the URL, it doesn't! I have the URL set up as an A record in our DNS; maybe that has something to do with it... – Dan Feb 7 '13 at 19:03
  • That does sound odd, I'm not sure how to get AFP working in your DNS Zone file; an A record sounds good to me though. Are you trying to connect via DNS only internally? – sofly Feb 8 '13 at 17:58
  • Sorry, I don't know what 'connect via DNS only internally' means ... You mean over LAN? No, I'm trying to connect from LA to New York. – Dan Feb 8 '13 at 23:36
  • Poor description from me. Yes, I was curious if you were trying to connect using an external IP over LAN, but it sounds like you're not. I guess it's gotta be DNS or firewall somehow. – sofly Feb 10 '13 at 18:47

You must log in to answer this question.

Browse other questions tagged .