I have a private folder on my drive that I keep personal docs in and i want to make it password protected. So I thought I would click Get Info > make it write only in the Sharing & Permissions section > lock it in the General section, then click the padlock at the bottom corner to prevent changes, which means if anyone wants to get access to the folder, they would have to click the padlock, type in a password, uncheck the Locked tick and then change the permissions to read & write.

This worked for a while, but now when I access the folder, I go through all those steps and when I click the padlock, I don't hear the locking noise and I can still make changes to the folder.

Is there a setting somewhere that I need to fix/unfix? Is there something in Terminal I can do to make this folder password protected?

  • I don't understand what you think you're accomplishing. Do other users physically use your computer? Do they have different accounts or the same account? Are any of them administrative users? – Daniel Feb 6 '13 at 1:49
  • I use my computer for school projects where I need other students and instructors to take over my laptop. And I don't want them to get into this private folder on accident. – OghmaOsiris Feb 6 '13 at 1:51

If your goal is to prevent someone accidentally stumbling into a folder, making the folder un-readable through the Finder dialog would likely accomplish that goal (and without needing a password — one is unlikely to "accidentally" open the File Info dialog, change the permissions settings, then open the folder.

If you are concerned about some snooping that isn't quite accidental, you really need more protection. I'd recommend using an encrypted disk image. That way you can give your folder real password protection, and the password you use doesn't have to be the system password (which users of your computer might need to know).

  • I tried doing a disk image, but I would have to decide how big the image will be before setting it up, and the folder will probably be increasing in size. – OghmaOsiris Feb 6 '13 at 13:30

I don't know why the Get Info dialog isn't working anymore, but if you want to remove read permission from a folder in Terminal, you can type chmod -r folderName. You can add read permission back by typing chmod +r folderName.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .