My Mac Book Pro 13.-" doesn´t get past the grey booting screen with the apple and the spinning wheel (The loading bar appears but when it´s done nothing happens)

I have 220 GB in one single Partition (Macintosh HD) and there is all my work my music and the only copy of ALL MY PHOTOS. I´m so stupid I don´t have a backup of anything but know I have an external HD with 300GB space. I would like to repair my HDD but more important I need to save my files but I don´t know how to do it in Disk Utility Mode. I read there is a Diskwarrior but I don´t know how to install it without booting the mac. Please help!!!

When I start on Single User mode and enter /sbin/fsck -fs this appears

Executing fsck_hfs (version diskdev_cmds-557-393) 
Checking Journaled HFS Plus volume. 
The volume name is Macintosh HD 
Checking extents overflow file. 
Checking catalog file 
Incorrect number of thread records  (4, 23745) 
Checking multi-linked files. 
Checking catalog hierarchy 
Invalid volume directory count (It should be 175703 instead of 175701) Checking extended attributes file. 
Incorrect number of extended attributes (It should be 340062 instead of 340064) 
Checking volume bitmap. 
Checking volume information. 
The volume Macintosh HD could not be repaired after 3 attempts.

*****The volume was modified *****

What are the next steps if fsck fails to repair a drive?

  • I don't have enough reputations to answer this questionn. 1. Start in Single User mode (Command + S) 2. Mount / with write permissions (mount -uw /) 3. Make a backup of /sbin/fsck and /sbin/fsck_hfs 4. Create noop shell scripts for /sbin/fsck and /sbin/fsck_hfs and make them executable chmod +x ... 5. Boot your Lion 6. Make a full TimeMachine Backup 7. Restart in recovery mode (Command + R) and restore your TimeMachine backup 8. Restore original /sbin/fsck and /sbin/fsck_hfs This helped me.
    – bjmi
    Commented Mar 25, 2021 at 4:27

3 Answers 3


You can try this but please make sure you backup first:

Boot to single-user mode, hold down the command (i.e. cloverleaf or Apple) and "s" keys as the system begins to boot.

To Debug, Repair, Force (and fix errors automatically)

/sbin/fsck_hfs -drfy /dev/disk0s2

To scan for bad blocks:

/sbin/fsck_hfs -S /dev/disk0s2

Assuming disk0s2 is the one you are looking to repair. (Usually the default "Macintosh HD" drive.)

This should get you back inside your OS.

This link may help too: http://www.westwind.com/reference/os-x/commandline/single-user.html

  • The 2ND part of the solution to scan for bad blocks doesn't work. Says that S is invalid. Is that a typo?
    – user173292
    Commented Feb 28, 2016 at 14:10
  • @user173292 it works just fine in my end.
    – cregox
    Commented Apr 27, 2017 at 20:43
  • 4
    Had to run the fck_hfs -drfy command twice until it was successful.
    – knedlsepp
    Commented May 30, 2017 at 17:31
  • 3
    @knedlsepp Can't thank you enough for making me try this multiple times — several days of work safely recovered!!!
    – Asmus
    Commented Jan 30, 2018 at 15:00
  • 1
    doesn't work for me.. fck_hfs -drfy respond Disk full error CheckHFS returned 8, fsmodifier = 0. there is 14GB free on my 120GB SSD.
    – Alexey Sh.
    Commented Sep 21, 2018 at 22:24

To add here I had the similar situation. The steps I took:

  1. Boot in single mode.

  2. Run /sbin/fsck_hfs -drfy /dev/disk0s2 many times, it didn't help. In the output I noticed there is a circular link problem, the messages were something like parentID=334973 threadID=51569281. The file ids are actually inode numbers and correspond to real files.

  3. Run find / -inum 334973 to figure out which file is a problem, it appeared the file inside .Spotlight folder.

  4. Remounted disk in rw mode and deleted spotlight folder, then rebooted in single mode again.

  5. Run /sbin/fsck_hfs -drfy /dev/disk0s2 again and now the problem was fixed since problematic file was deleted.

  • Brilliant!! Now that's some real Root Cause Analysis. I tip my hat to you, sir. Commented Feb 13, 2019 at 13:32
  • how did you go about deleting the Spotlight folder?
    – pjldesign
    Commented Dec 7, 2020 at 22:31

At this point, your options are as follows:

  1. Pay for technician time to re-run the Apple steps in case you did them incorrectly / missed a step / clue (unlikely, but possible)
  2. Pay for / search for software that does more to repair a drive's data catalog than Disk Utility. Of the many commercial products, Disk Warrior is what most use, but Data Rescue might work as well.
  3. Erase the HD - losing all data, and see if this was simply a catalog corruption that Disk Utility was unable / unwilling to repair (pretty fair chances)
  4. Replace the HD - postponing whether the data can be saved, but getting a good drive in the Mac so you can test if it's the drive / particular data on that drive or the Mac needs repair.
  5. Pay for a repair tech to do the repair.

Unless you have data that's valuable (in that you might pay between $100 and $1000 dollars to have professional recovery help), I would pick one of the inner two options which means buy a new drive (benefits are fixed sunk cost and limited investment of time to troubleshoot) or look extended troubleshooting like Disk Warrior or erasing the drive if you have a backup, don't really need one.

  • thanks bmike 2 questions: 1. Do you think the genius in the apple store will be able to help? and 2. How do I install Diskwarrior if I can´t boot my mac? Thank you for your answer
    – BenCis
    Commented Feb 5, 2013 at 13:32
  • Yes - the Genius Bar sees this problem and helps people understand options tens of times each day/week. Optical media, recovery HD or external drive would all boot your Mac in most cases.
    – bmike
    Commented Feb 5, 2013 at 14:19
  • DiskWarrior comes on a bootable DVD, from which you then run the utilities.
    – IconDaemon
    Commented Feb 5, 2013 at 15:58
  • Thank you very much. On Saturday I have an appointment at the Genius Bar.
    – BenCis
    Commented Feb 5, 2013 at 20:13
  • 1
    I ran the command a 2nd time and second time around it worked
    – Wadih M.
    Commented Jun 24, 2015 at 19:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .