I got a question of one of my customers:

They are experiencing problems when connecting a iPod to a WIFI LAN without Internet connection.

Basically, the iPod connects, gets a IP from DHCP, but then it can't reach a local Intranet server (with Safari to http://172.16.2.n).

We can ping the iPod, but thats all. And, once we connect the LAN to the Internet, everything works again.

I tried the same with my iPhone 4(v6), that seems to work fine. Also with IOS 5 it works (both without Internet connection).

Anybody a clue?


  • I would suggest going into Settings on the iPod touch, drilling into the WiFi network, and selecting "Forget this network". Then try connecting again. If that doesn't work, I would recommend a restore. If it is properly resolving DHCP and DNS, it should be able to route to your local intranet server. – bispymusic Mar 11 '13 at 21:33
  • Thank you. We tried that, including factory reset (and restore). But no cigar :/ – Roger Mar 11 '13 at 22:51
  • Is the iPod in the same range as the local intranet server (that is, in 172.16.2.x)? It could be a problem with the default gateway, check if the iPod gets it from the DHCP server. Check the network mask, too. – jaume Mar 20 '13 at 9:41
  • I am seeing exactly the same issue with a router connected to local intranet, but no internet connection. Works on iOS6 and iOS8, but not iOS7. Did you ever find a solution? – BlueChippy Jan 5 '15 at 7:15
  • @BlueChippy well you should double check the netmask and gateway as its given by the DHCP server. You could try entering it by hand. – Roger Jan 8 '15 at 23:17

Well, I'll take a crack at this one. I see three possibilities: 1) the packets are not leaving the iPod; 2) the packets are being dropped somewhere along the path; 3) there is a DNS related issue.

Lets start with DNS.

From the iPod try connecting to the Intranet server using the Intranet server's IP address instead of its name. If this works than either the DNS setting in the iPod's association to the WiFi network is incorrect or the search domain is incorrect. You can check this by going to Settings->WiFi->your_wifi_network_name. If these look incorrect, try to "Forget this Network" and then reconnect.

If you still have the problem then it gets a bit more tricky

Go the App Store and get an nslookup app and a traceroute app for your iPod. Several are free and work fine. Make sure neither of the apps require a internet connection to work. Once you have the apps, open the nslookup app and enter the DNS name of your Intranet server (ex. www.myserver.local). It should return the internal IP address of the server (i.e. it should not return the internet reachable address (if it even has one)). If it does return the correct address then take that address and use it as the input for the traceroute app. The traceroute should tell you all the IP hops it takes to get to the Intranet server. If it gets so far and then stops without getting to the Intranet server's IP address then we have a network problem to troubleshoot. If it does then we have an Intranet server problem to troubleshoot.

If traceroute gets all the way to the Intranet server then turn on the detailed connection logging on the Intranet server. Then, from the iPod, try to connect to the Intranet server. Now, look at the log file on the Intranet server and see if you see the iPod IP trying to connect and if so, what error is generated. Troubleshoot the error.

If traceroute does not get the Intranet server then turn debug logging on the network devices that sit between the iPod and the Intranet server. The traffic is making it somewhere and then being dropped. Find where it is being dropped and troubleshoot why it is being dropped.

NOTE: If traceroute never leaves the iPod and/or you do not see traffic on the first device that the iPod is connected to then the problem may be within the iPod itself. If that is the case then gulp do the normal iPod stuff like reset it/reload it/etc. (I hate it when someone tells me to do that!)

I hope this was of some help to someone and that I didn't ask you to chase a red herring


I've found the following apps helpful: Fing & IP Network Scanner. Both have free and pro versions. Also, via Cydia, is Netatalk. A true champion among iOS networking solutions. Really, it's amazing. "Netatalk is a free, open-source implementation of AppleTalk for Unix systems. Installing this package will let you use standard Apple file sharing to connect to your iPhone."

  • 1
    Appletalk is not part of the OPs question the question is plain IP. How doe the apps you mention show the issues the OP has? – user151019 Jun 6 '13 at 14:37
  • Fing and IP Network Scanner show all the IPs on your network as well as sorting by IP, MAC add, & last changed. It's quite useful. I see the tangent I went on RE: appletalk and apologize for this. – PacoSF Jun 9 '13 at 23:20

Do you have a VPN on the network? You may need a VPN app on the iOS device. (You may have set one up on your iPhone 4 V6 but forgot.)


Try assigning a static IP address and manually insert the Subnet Mask and Router Address (DHCP).

  • Can you explain in more details how to do this and how this will solve the problem the asker is facing? – nohillside Jul 27 '13 at 15:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .