I run Mountain Lion, a fresh install, brand new Macbook Pro. HD: Samsung 840 Pro 512 GB SSD.

When trying to go through Boot Camp Assistant / Setup it works fine until it wants to repartition my drive. It then quits unexpectedly and returns these errors:

Exception Codes: KERN_INVALID_ADDRESS at 0x000000000000003c

Everything else on this new machine works like a charm. I checked permissions, verified the disk - no issues whatsoever.

I tried running the Assistant as root - it also crashes when partitioning but then in the Terminal i get a

Segmentation fault: 11

Can anyone help me out with this?

Screenshot #1 Screenshot #2

  • I have not been able to solve the issue, but i was able to find a full workaround. As Boot Camp Assistant crashes AFTER it creates the USB drive with the BC drivers for Windows, i just partitioned the harddisk again myself (in Disk Utility) and then booted up manually and normally with the Windows 7 CD, installed Windows 7 on the target partition and then installed the BC drivers from the USB drive. Everything works perfectly well. Feb 5, 2013 at 10:12
  • Great you could find a workaround. I'd suggest that you answer your own question describing the workaround as you've done in the comment and mark the answer as accepted.
    – jaume
    Feb 5, 2013 at 10:49

5 Answers 5


Run Repair Disk on your boot partition. To accomplish this, reboot your Mac into the recovery partition, holding down ⌘R when you see the Apple logo. Select Disk Utility from the menu, then in the First Aid tab click Repair Disk. This may take some time. Partitioning trouble is usually a file system or disk hardware problem; this will solve the former, and a trip to the Apple store is usually needed to address the latter.


For me it crashed when accessing the USB drive. I reformatted my USB as Mac OS extended via Disk Utility and was able to continue after that.

  • For me, this worked but it turned out I then needed to reformat the USB as MS-FAT32. Oct 5, 2017 at 8:52

I just found a solution that might work for you... Unplug all the external devices that you might have (external disks, flash drives) and then start the bootcamp again.. I just did it and it worked fine for me!!! :)

  • Did not work for me back then - i had nothing connected whatsoever. Mar 22, 2013 at 11:15

I remember having this issue as well when I tried using bootcamp. I seem to remember that it was due to a fragmented drive that didn't have enough contiguous space to create the partition of the size I was requesting. From memory, it was a bit of a pain and I think I ended up partitioning the drive first, then reinstalling OS X on one partition and using Winclone to copy a windows machine directly to the other partition. There may well be an easier method?


put windows 7 or later version dvd and then you will be able to make partition with BC :)

  • this will definetly work dude... Jul 19, 2013 at 16:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .