My iMac 27" (late 2009, 10.8.2) wifi (3-4 bars) speed doesn't compare to other computers at home. The same Youtube video in 720p loads without delay on my dads computer, however on my iMac (I usually just watch 360p or 240p) because it's so slow.

Now I messed a lot with network preferences when setting up servers and stuff so these speed issues are probably my fault. Strangely Speedtest.net shows the same results as any other computer on the network, but youtube just doesn't work well.

Are there any things I should try? Is there any way to restore defaults? I wasn't able to find the "/Library/Preferences/SystemConfiguration/preferences.plist" as mentioned on some blogs.

I'm also considering reinstalling Mountain Lion cause I have some issues with loud disk activity even when I'm not using the computer. Would this delete all my files and apps? Would it fix the wifi problems I have? How much changes does it do when I install it on my HDD that already has Mountain Lion installed.

All answers will be greatly appreciated.

- Wifi info:
PHY Mode: 802.11n
BSSID 00:17:3f:3b:64:7c
Channel: 3 (2.4GHz)
Security: WPA Personal
RSSI: -55
Transmit Rate: 54
MCS Index: 0
  • Did you try to put your Mac into the same location as the PC to compare the speed? Did you move the base station to see whether this makes a difference? There are a lot of things influencing a WiFi signal. Alternatively you could try to boot from the Recovery Partition/DVD and check speed from there. – nohillside Feb 3 '13 at 15:10
  • The computers are in different rooms. Both of them have full bars on connection. I forgot to mention that I use to watch 1080p youtube videos on the imac without a problem some time ago. – Matthew Abrman Feb 3 '13 at 15:14
  • What browser are you using to watch Youtube videos? If it's just Safari have you tried alternate browsers (i.e. Google Chrome or Mozilla Firefox)? – Mort Feb 3 '13 at 15:21
  • I normally use chrome, just tried safari, same results. – Matthew Abrman Feb 3 '13 at 15:23
  • Simple question, does your rate goes up if you disable other computers. Your MCS Index shows zero ? – Ruskes Apr 9 '13 at 17:10

I stumbled on this question because I'm having problems with poor wifi speeds after installing Yosemite on a July 2014 rMBP. I don't get drops, but I get 5 Mbps speeds literally 5 feet from the router when I used to get in the 70s. My iphone 5S, sitting next to the rMBP, is able to get 70Mbps. Even more confounding is that if I change the router to support only 802.11g, the speeds are at 54Mbps.

What I learned is that "MCS Index" value is significant--it communicates from the Access Point to the clients what coding schemes are in use. There is a standard table defined by 802.11n, and you can view it here: http://en.wikipedia.org/wiki/IEEE_802.11n-2009

In your case--and in mine--an MCS Index value of zero shows up. According to the table at the link above, that means the maximum rate available should be 6.5-7.5 Mbps. However, in your output, it claims you're getting 54Mbps, which seems wrong.

So, why am I answering? Because in both cases, the evidence suggests that Apple's driver or the chipset is doing the wrong thing with the MCS Index value. In my case, I sniffed wireless lan traffic and confirmed using wireshark that the AP is announcing itself with an MCS Index value of "7" (conforming to what I actually set in the configuration for the AP). Yet, my rMBP insists that it's a zero and sets the speed accordingly. In your case, it appears to be recognizing the MCS Index value as zero but setting the speed incorrectly.

In short, I'm not sure that reinstalling your will actually change anything for you.

| improve this answer | |
  • Thanks for the answer, I don't remember how I solved it one and a half years ago, had replaced router once or twice from since then. Anyways hopefully your answer will be of help to someone else. :) – Matthew Abrman Nov 12 '14 at 16:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .