I have a mid-2009 15" MacMook Pro, with 10.8.2 installed. Periodically, after sleeping my machine, I open it and hit a kernel panic. The logs fail at the AppleIntelCPUPowerManagementClient kext, and I don't see any non-Apple related kexts in the crash log. Any idea what could be causing this? Hardware failure perhaps?

Wed Jan 30 20:16:32 2013
panic(cpu 0 caller 0xffffff800e4b7bd5): Kernel trap at 0xffffff800e42da10, type 13=general protection, registers:
CR0: 0x000000008001003b, CR2: 0xffffff80effc5000, CR3: 0x00000000110ac000, CR4: 0x0000000000000660
RAX: 0x0000000000000001, RBX: 0xffffff80206e3000, RCX: 0x0000000009000000, RDX: 0xffffff80e9f60078
RSP: 0xffffff80f57c3e50, RBP: 0xffffff80f57c3e80, RSI: 0xffffff80e9f60068, RDI: 0x0000000000000000
R8:  0xffffff800eabec60, R9:  0x00000000fffffffe, R10: 0x00000000001d9bc0, R11: 0x0000000000000000
R12: 0xffffff800eabebe8, R13: 0xffffff8020711ad0, R14: 0x01ffff8020711aa0, R15: 0x0000000000000000
RFL: 0x0000000000010002, RIP: 0xffffff800e42da10, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0xffffff80effc5000, Error code: 0x0000000000000000, Fault CPU: 0x0

Backtrace (CPU 0), Frame : Return Address
0xffffff80f57c3af0 : 0xffffff800e41d626 
0xffffff80f57c3b60 : 0xffffff800e4b7bd5 
0xffffff80f57c3d30 : 0xffffff800e4ce4ed 
0xffffff80f57c3d50 : 0xffffff800e42da10 
0xffffff80f57c3e80 : 0xffffff800e82e1e9 
0xffffff80f57c3ec0 : 0xffffff800e82ca47 
0xffffff80f57c3f30 : 0xffffff800e82d3a2 
0xffffff80f57c3f70 : 0xffffff800e831e99 
0xffffff80f57c3fb0 : 0xffffff800e4b26b7 

BSD process name corresponding to current thread: kernel_task

Mac OS version:
Not yet set

Kernel version:
Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64
Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333
Kernel slide:     0x000000000e200000
Kernel text base: 0xffffff800e400000
System model name: MacBookPro5,3 (Mac-F22587C8)

System uptime in nanoseconds: 1680101793
last loaded kext at 227453939: com.apple.driver.AppleIntelCPUPowerManagementClient  196.0.0 (addr 0xffffff7f902ca000, size 20480)
loaded kexts:
com.apple.driver.AppleIntelCPUPowerManagementClient 196.0.0
com.apple.driver.AppleFWOHCI    4.9.6
com.apple.driver.AirPort.Brcm4331   602.15.22
com.apple.nvenet    2.0.19
com.apple.driver.AppleUSBEHCI   5.4.0
com.apple.driver.AppleSmartBatteryManager   161.0.0
com.apple.driver.AppleAHCIPort  2.4.1
com.apple.driver.AppleEFINVRAM  1.6.1
com.apple.driver.AppleUSBOHCI   5.2.5
com.apple.driver.AppleRTC   1.5
com.apple.driver.AppleHPET  1.7
com.apple.driver.AppleACPIButtons   1.6
com.apple.driver.AppleSMBIOS    1.9
com.apple.driver.AppleACPIEC    1.6
com.apple.driver.AppleAPIC  1.6
com.apple.nke.applicationfirewall   4.0.39
com.apple.security.quarantine   2
com.apple.driver.AppleIntelCPUPowerManagement   196.0.0
com.apple.iokit.IOFireWireFamily    4.5.5
com.apple.iokit.IO80211Family   500.15
com.apple.iokit.IONetworkingFamily  3.0
com.apple.driver.NVSMU  2.2.9
com.apple.iokit.IOAHCIFamily    2.2.1
com.apple.iokit.IOUSBFamily 5.4.0
com.apple.driver.AppleEFIRuntime    1.6.1
com.apple.iokit.IOHIDFamily 1.8.0
com.apple.iokit.IOSMBusFamily   1.1
com.apple.security.sandbox  220
com.apple.kext.AppleMatch   1.0.0d1
com.apple.security.TMSafetyNet  7
com.apple.driver.DiskImages 344
com.apple.iokit.IOStorageFamily 1.8
com.apple.driver.AppleKeyStore  28.21
com.apple.driver.AppleACPIPlatform  1.6
com.apple.iokit.IOPCIFamily 2.7.2
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.corecrypto    1.0
  • have you done anything to determine whether it is a software or hardware problem?
    – Macmaniman
    Jan 31, 2013 at 15:52
  • 1
    Nope, I'm not sure where to start.
    – Julio
    Jan 31, 2013 at 18:22
  • I'm experiencing the exact same problem since last tuesday, when I installed the latest Mountain Lion update that corrected some battery flaws from older macs. I had never experienced said flaws, but figured out it was better to update the OS and "prevent" them. Have you installed that update? Feb 1, 2013 at 15:40
  • Yes, I believe I recently updated. I'd experienced these before, since updating to 10.8, however not as bad as they were they other day (kernel panicked and restarted about 8 times).
    – Julio
    Feb 1, 2013 at 15:53
  • 2
    Use an nvram(8) command to add the following boot-arg (boot argument). Then restart the Mac. With this in NVRAM, the next .panic file will be more understandable and informative: keepsyms=y Aug 2, 2014 at 19:07

7 Answers 7


If you want to determine whether your panic is caused by hardware or software problems, I recommend you to install Mac OS 10 on a USB stick, it needs to be at least 8 GB. Boot up from it. Now try sleeping. If it's ok, its most likely (99%) a software problem. It may also be your HDD, which is highly unlikely.


After the panic, do two cold restarts in Safe Mode. (A cold restart is booting up from the system completely off. You can get into Safe Mode by holding down left shift key while powering up.) That is, hold down left shift key immediately after pressing the Power button. You may release the Shift key when you see the radial start to spin. Do this twice then boot into regular mode by booting normally. By doing this you will allow the system to check itself and repair any errors it finds, this also checks and repairs permissions. Restarting clears the memory and therefore any faults stored in memory. My experience tells me a panic is either the volume directories or bad memory (RAM).


If KPs continue after safe boot, then most likely they're hardware related. Run the Apple Hardware Test suite, extended tests at least twice, followed by Rember. See

this link https://discussions.apple.com/message/21725938#21725938


Recently happened to me on my 2011 iMac. Tried Safe Mode but kept rebooting. Only thing that worked was CMD-R for Recovery and reinstalled Mavericks. Smooth ever since.


If you have installed any RAM on the machine, try removing it and using only the original Apple RAM modules. This has resolved better than 9 in 10 of the kernel panics I've had on Intel machines. If it does, get replacement RAM modules from your vendor.


I have seen another fix-- a friend booted into recovery partition (cmd r at boot) and repair your disk from the disk utility there. He now has no problems whatsoever with his old mac.


If you use Clover, probably could be the culprit due to wrong CPU definitions.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .