1

During the Mountain Lion installation I have selected the English language as the system language. However, the dialog asking for my password – that appears when you need to install an application, or when you want to unlock a preference pane – is in Dutch. I'm currently in The Netherlands, but I don't see how this might be related to the language of one type of dialog.

Here below an image of the dialog. As you can see there's even a mix of Dutch and English: enter image description here

I haven't been to other countries yet with this MacBook Pro, so don't know if it's actually dependent on location.

How can I fix this issue?

3 Answers 3

1

In the end I solved the problem by removing all languages except English from the list found in System Preferences -> Language & Text and restarted.

0

I've encountered the same in Netherlands. I just switch the language once OSX installation is complete (and before I run Migration Assistant).

8
  • Do you mean that you switch the language in the language and text pref panel? I have English as the first, and Dutch as the second. Removed Dutch from the list, but the problem persists. I have already used migration assistant to migrate from a SL install. I only migrated the User folder, not the settings. Jan 30, 2013 at 20:17
  • Yes, that's what I mean. I let the OSX install complete until I see the desktop, then I change the language setting in International preference pane and reboot. Jan 31, 2013 at 6:18
  • I did this, but it didn't solve the problem. Jan 31, 2013 at 6:55
  • Everything still in Dutch despite language set to English? Even after reboot? Jan 31, 2013 at 8:15
  • 1
    let us continue this discussion in chat Jan 31, 2013 at 8:58
0

A few things you could try:

  • Run sudo languagesetup, select a new language, and restart.
  • Run sudo defaults write /Library/Preferences/.GlobalPreferences.plist AppleLocale en_US and restart.
  • Run sudo /System/Library/CoreServices/Setup\ Assistant.app/Contents/MacOS/Setup\ Assistant, go through the steps of creating a new account, restart, and delete the account.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .